Extremely poor scalability on nested tables

VERIFIED DUPLICATE of bug 61684

Status

()

P3
normal
VERIFIED DUPLICATE of bug 61684
18 years ago
11 years ago

People

(Reporter: jwbaker, Assigned: karnaze)

Tracking

({perf})

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Mozilla exhibits very poor scalability when rendering nested tables, such as the
excessively marked-up pages of http://www.kuro5hin.org/.  When viewing the URL
http://www.kuro5hin.org/?op=displaystory;sid=2000/10/20/16261/167 Mozilla
requires 1 minute, 12 seconds o render the page, while Netscape 4.75 requires
only six seconds.  The markup is 230 KB long.

If you use the form on the page to change the display to "Nested", Mozilla
spends over ten minutes rendering the page (before I killed it), while Netscape
4.75 requires 16 seconds to do the job.

It seems we have some code whose scalability is significantly worse than
linear.  These test cases are not pathological inventions, they are sites that
exist in the wild.
Assignee: clayton → karnaze
Reassigning to karnaze.
(Assignee)

Comment 2

18 years ago
Marking mozilla0.9
Target Milestone: --- → mozilla0.9

Comment 3

18 years ago
*** Bug 64140 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
This is highly likely to be a duplicate of bug 61684. That one has more info, so
you might like to migrate to that one?

Comment 5

18 years ago
Why not a dupe of bug 60494: "Mozilla is extremly slow rendering this page lots
of <font> tags"?

(Assignee)

Comment 6

18 years ago
I compiled with DEBUG_TABLE_REFLOW_TIMING and found that the tables are not to 
blame for the excessive slowdown. This is after the most recent checkins 
improving the performance of tables. I'm marking this a dup of bug 61684 based 
on comments and the similar url.

I do know that nested tables are still causing performance problems in many 
cases, but this is not one of them.

*** This bug has been marked as a duplicate of 61684 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verifications.  Tests (if necessary) were done with 2001052504 on Windows 2000.

Please forgive the spam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.