Invalid code in moznbytetype.m4

RESOLVED FIXED in mozilla2.0b2

Status

RESOLVED FIXED
8 years ago
6 months ago

People

(Reporter: sharparrow1, Assigned: sharparrow1)

Tracking

unspecified
mozilla2.0b2
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 458130 [details] [diff] [review]
Patch

Return without expression in a function returning "int" is not valid; attached fixes this.  clang defaults this to an error, unlike gcc.
Attachment #458130 - Flags: review?(ted.mielczarek)
Attachment #458130 - Flags: review?(ted.mielczarek) → review+
Eli, do you have commit access to mozilla.org's repos?
(Assignee)

Comment 2

8 years ago
Not at the moment... I filed a bug to reactivate my account, but I'm not sure how long that'll take.
Keywords: checkin-needed

Updated

8 years ago
Assignee: nobody → sharparrow1
http://hg.mozilla.org/mozilla-central/rev/d9d236a8d274
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b2
Duplicate of this bug: 596645

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.