The default bug view has changed. See this FAQ.

Page Info - Permissions, Ineffectual on https: sites

RESOLVED FIXED in seamonkey2.1a3

Status

SeaMonkey
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: therube, Assigned: ewong)

Tracking

({regression})

unspecified
seamonkey2.1a3
x86
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100718 SeaMonkey/2.1a3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100718 SeaMonkey/2.1a3pre

 
On an https: website, changes made via Page Info | Permissions are ineffectual.
 

Reproducible: Always

Steps to Reproduce:
 
1. Load http://bugzilla.mozilla.org
2. View | Page Info (or Ctrl+I) -> Permissions (tab)
3. Make a change
 
Actual Results:  
 
Changes are not effectual.
 

Expected Results:  
 
Changes should be effectual.
 

 
Broke between 2010 7/14 & 7/15.
Note that none of the square check boxes are checked (& you would expect them to be by default).
 
 
Error Console:

Error: Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIPermissionManager.add]
Source file: chrome://navigator/content/pageinfo/permissions.js
Line: 175
 
 
Line 175:

  permissionManager.add(gPermURI, aPartId, permission);
 
 
Context:

function onRadioClick(aPartId)
{
  var permissionManager = Components.classes[PERMISSION_CONTRACTID]
                                    .getService(nsIPermissionManager);
  var radioGroup = document.getElementById(aPartId + "RadioGroup");
  var id = radioGroup.selectedItem.id;
  var permission = id.split('-')[1];
  permissionManager.add(gPermURI, aPartId, permission);
}
 
 
> Ratty: There have been some recent changes in the Permissions code due to e10s (multiprocess tabs) landing. Perhaps something there broke us.

> Ratty: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2010-07-14&enddate=2010-07-16
> Ratty: probably Bug 564535 - permission manager needs to be remoted

Updated

7 years ago
Blocks: 564535

Updated

7 years ago
No longer blocks: 564535

Comment 1

7 years ago
Actually I think this is a regression from bug 539174, it probably just needs the security.js changes ported over.
Blocks: 539174
Keywords: helpwanted, regression
Whiteboard: [good first bug]
(Assignee)

Updated

7 years ago
Assignee: nobody → ewong
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Did we port this code over to Seamonkey?  If it isn't, then it's probably not a regression from the Firefox change since the two Page Info instances are branched.

Comment 3

7 years ago
Tanner, you touched a properties file that is shared with Firefox but you didn't make the equivalent changes in the SeaMonkey XUL.
(Assignee)

Comment 4

7 years ago
Created attachment 459994 [details] [diff] [review]
Fixed a regresion from bug 539174
Attachment #459994 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #459994 - Flags: review? → review?(neil)

Updated

7 years ago
Attachment #459994 - Flags: review?(neil) → review+

Comment 5

7 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/f502c0e0223e

Thanks Edmund!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Keywords: helpwanted

Updated

7 years ago
Target Milestone: --- → seamonkey2.1a3
You need to log in before you can comment on or make changes to this bug.