Connection Untrusted screen should have "allow this once".

RESOLVED DUPLICATE of bug 410240

Status

()

RESOLVED DUPLICATE of bug 410240
9 years ago
9 years ago

People

(Reporter: pwd.mozilla, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre

Currently if you end up at the "Connection Untrusted" screen you're forced to add an exception. Users shouldn't be forced to add an exception, in fact this behaviour shouldn't be encouraged at all, Firefox should instead promote an "allow once" action with a "Create Exception" being an 'Advanced Option'.



Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
I appreciate trying to keep the user safe, but the current UI is not an accident. We believe that permanent exceptions by default are the safer approach - dramatically reduces dialog fatigue, doesn't represent a meaningful increase in risk of pwnage since those attacks will almost always be perpetrated on the first connection.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410240
You need to log in before you can comment on or make changes to this bug.