2nd print dialog on OK, Cancel when printing from the menu on the icon

VERIFIED DUPLICATE of bug 53189

Status

P3
normal
VERIFIED DUPLICATE of bug 53189
18 years ago
11 years ago

People

(Reporter: ji, Assigned: bugzilla)

Tracking

Trunk
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
***observed with Win32 and linux 20001025 branch build***

When printing from the menu listed from the arrow on the printing icon, clicking 
on OK button doesn't close the print window.

Steps to reproduce:
1. Launch Mail.
2. Select a mail
3. Click on the small arrow on the printing icon and select Print menu item.
4. Click on OK button on the Print window. The mail is printed out, but the 
print window doesn't go away.

Printing from File |Print or clicking on the print icon doesn't have this 
problem. Printing from browser doesn't have this problem either.

Comment 1

18 years ago
*** Bug 57987 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Works fine for me (print window closes on OK) with linux rh6.0 and Win98 using
oct25 mn6 commercial branch build.
QA Contact: esther → fenella
Summary: Clicking on OK button doesn't close print window when printing from the menu on the icon → Clicking on OK button doesn't close print window when printing from the menu on the icon

Comment 3

18 years ago
hmm... works fine for me on WIn NT 40, i am able to close both dialogs coming
from mail and browser
(Reporter)

Comment 4

18 years ago
This problem only occurs when you print a mail from the menu on the print icon.
You can see the menu if you click on the small arrow on the print icon.

Comment 5

18 years ago
Ok, i am able to close it from the first click when i am clicking on the icon
and on the second OK click when printing from the drop-down list...

Comment 6

18 years ago
I did it from the print icon as you originally described. It still works for me
using today's commercial build.
(Reporter)

Comment 7

18 years ago
It's not from the print icon, it's from the drop-down list on the print icon.

Comment 8

18 years ago
Look, I did the dropdown Print item off the icon... it still works for me.

Comment 9

18 years ago
Linux (2000-10-25-09 MN6)
Win32 (2000-10-25-09 MN6)
Mac (2000-10-25-08 MN6)
I follow the same scenario as described by the originator, I cannot reproduce
the problem either.
(Reporter)

Comment 10

18 years ago
I have to click Ok button twice to close the window. I saw this on Marina's 
machine too.

Comment 11

18 years ago
I do agree that I have to click on the OK button twice to close the window. But
that is not what's described in step 4, though.

Comment 12

18 years ago
Changed the summary
Summary: Clicking on OK button doesn't close print window when printing from the menu on the icon → 2nd print dialog on OK, Cancel when printing from the menu on the icon

Comment 13

18 years ago
In some instances, I'm seeing that the second print dialog hides behind some
open window... so you don't always notice there's a second print dialog.

Comment 14

18 years ago
I do agree with Laurel.

Comment 15

18 years ago
I think this is a UI issue, either for XPFE or Mail.  
Don can you assign to one of your engineers.. or forward to the mail group..
Thanks
Assignee: dcone → don
(Assignee)

Comment 16

18 years ago
Huh? This should already be fixed with by checkin for bug 53189.  If I missed a 
case somehow, let me know.  But this works for me...
Assignee: don → blakeross

Comment 17

18 years ago
This bug was logged using branch build, whereas the fix for 53189 is applied to
the trunk only.

I'll mark this a duplicate, as I doubt anyone would nominate this for a branch fix.
(Assignee)

Comment 18

18 years ago
ahh...that's right.  really marking dup...

*** This bug has been marked as a duplicate of 53189 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 19

18 years ago
Mark it a verified/dup.
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
*** Bug 58017 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.