If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Render Chrome and Window in Parallel

RESOLVED DUPLICATE of bug 577208

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 577208
7 years ago
7 years ago

People

(Reporter: John Wayne Hill (UX Intern), Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
In order to make startup time feel as fast as possible, we should be rendering the window chrome and the window at the same time instead of sequentially. This would greatly improve the startup experience and make Firefox seem faster. 

Recommendation:
1. render chrome and window in parallel

This is also a Chrome parity.
This is probably mostly bug 130078.
Depends on: 130078
Try builds with bug 130078 are available at http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/tnikkel@gmail.com-5385f18dfbc5/ if anyone wants to test how this is going to look after 130078 lands.
(Reporter)

Updated

7 years ago
Blocks: 580046
Requesting blocking the final release of Firefox 4.  Drawing in the title bar on windows has resulted in a very strange start up experience (the whole top of the window is missing on launch, and then it draws in).
blocking2.0: --- → ?

Comment 4

7 years ago
Dupe of Bug 577208?

Comment 5

7 years ago
(In reply to comment #3)
> Requesting blocking the final release of Firefox 4.  Drawing in the title bar
> on windows has resulted in a very strange start up experience (the whole top of
> the window is missing on launch, and then it draws in).

Alex, any chance we might be able to get some of your slow motion video goodness of the browser loading on a glass desktop?

(In reply to comment #4)
> Dupe of Bug 577208?

Looks like it.
Created attachment 459567 [details]
Screen capture of launching with aero glass enabled

>Alex, any chance we might be able to get some of your slow motion video
>goodness of the browser loading on a glass desktop?


This is a lower frame rate than the videos taken with an external camera, but the screen capture shows the drawing artifacts better (like the curvature of the top of the window on the left glass border).

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577208

Updated

7 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.