won't save authentication method "normal password" as preference

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Profile Migration
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Benedikt, Assigned: standard8)

Tracking

({regression})

1.9.2 Branch
Thunderbird 3.3a1
x86
Windows XP
regression
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-thunderbird3.1 .2+, thunderbird3.1 .2-fixed)

Details

(Whiteboard: [gs], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

After restarting thunderbird my preference of the authentication method gets lost and is set back to "Any secure method", even though before restarting the program, it remembers the set preference. Happens only with the selection "SSL/TLS" and "normal password". I'm using two mail-servers and this problem occurs only with the one referred to as mail.server.server1

I looked up prefs.js to find that thunderbird won't save the authMethod variable when its value is 3 (="normal password"). After editing the file manually everything works fine.

Reproducible: Always

Steps to Reproduce:
1. select "ssl/tls" for the mailserver of incoming mails in your prefs
2. select authentication method "password, normal"
3. restart program
Actual Results:  
the selected preference won't be saved; instead the preference turns to "Any secure method"

Comment 1

7 years ago
See http://forums.mozillazine.org/viewtopic.php?f=39&t=1955465&start=0 (which also has a link to a similar thread on the GetSatisfaction support forum)

They worked around the problem (in Thunderbid 3.1 and 3.1.1) by setting useSecAuth false.
I see this too after updating from T'bird 3.0.6 to 3.1.1, en-US build on mac 10.6. On an IMAP account I have 
  Connection security: SSL/TLS
  Authentication method: Any secure method (deprecated)
and get an alert on connection
  The IMAP server <blah> does not support the selected authentication method.
  Please change the 'Authentication method' in the 'Account Settings | Server
  settings'

If I go there and set it to 'Normal password' then I can login, but that change is lost after restarting Thunderbird. Peeving after the 3rd time.

How do I request blocking for this to get fixed in 3.1.x ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.1
Mark, we'll call me CC-ing you a blocking request for 3.1.x since it seems the flag permissions are set wrong (neither myself nor nthomas can REQUEST blocking for 3.1)
(Assignee)

Updated

7 years ago
blocking-thunderbird3.1: --- → .2+
(In reply to comment #3)
> Mark, we'll call me CC-ing you a blocking request for 3.1.x since it seems the
> flag permissions are set wrong (neither myself nor nthomas can REQUEST blocking
> for 3.1)

It ain't wrong just follow our policy. You both have access now.

Comment 5

7 years ago
Is there anything on the error console when you try to change the setting?
No, but perhaps the error would occur on shutdown. Is there an argument I can give at startup time to dump error console output to the terminal ?
(Assignee)

Comment 7

7 years ago
I just tried reproducing this but couldn't.

What I think may be useful to get is a copy of the mail.server.server<n>.* prefs where n is the server relating to the one you're having trouble with.
Keywords: qawanted
(In reply to comment #6)
> No, but perhaps the error would occur on shutdown. Is there an argument I can
> give at startup time to dump error console output to the terminal ?

-console does that normally
Created attachment 461397 [details]
mail.server.serverN.* prefs

I left out mail.server.server4.directory, not clear what that pref is.

Trying -console:
$ /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -console
Warning: unrecognized command line flag -console
Setting 
 Connection Security: None
 Authentication method: Password, transmittend insecurely
and restarting t'bird gives me
 Connection Secutiry: None
 Authentication method: Any secure method (deprecated)

I can't reproduce with a new profile either. Data migration routing gone wrong ? 

BTW, the Mozilla ISP settings sets SSL/TLS & Encrypted Password when the server needs Normal password.
(Assignee)

Comment 11

7 years ago
There's definitely something wrong here.

If I take my current profile, and set mail.server.default.authMethod to 8, then I see the authentication method as "Any secure method (deprecated)".

However, if I set mail.server.default.authMethod back to 3 and have mail.server.server7.authMethod set to 8, then that server shows "Normal Password".

As the specific server instance is meant to override the default one, there's something not right here.
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> If I take my current profile, and set mail.server.default.authMethod to 8, then
> I see the authentication method as "Any secure method (deprecated)".
> 
> However, if I set mail.server.default.authMethod back to 3 and have
> mail.server.server7.authMethod set to 8, then that server shows "Normal
> Password".

Unfortunately about:config had decided to set my server7.authMethod to a string value rather than integer, which is why this wasn't doing the expected.
(Assignee)

Comment 13

7 years ago
Ok, I can reproduce this now, STR:

1) Simulate a profile from Thunderbird 2 or 3: have mail.server.server<n>.useSecAuth set to true. Ensure mail.server.server<n>.auth_login unset.

2) Run Thunderbird 3.1 (or trunk), mail.server.server<n>.authMethod gets set to 8 by mailnewsMigrator.js i.e. "Any secure method (deprecated)".

3) Go into account settings and select "Normal password" for the authentication method.

=> At this stage mail.server.server<n>.authMethod gets *cleared* because it would be set to 3 but that's the value of mail.server.default.authMethod (hence it gets cleared).

4) Restart Thunderbird.

=> mailnewsMigrator.js sees authMethod not being set to a user value, and therefore re-initialises it to 8.
Blocks: 525238
Component: Preferences → Profile Migration
Keywords: qawanted → regression
Product: Thunderbird → MailNews Core
QA Contact: preferences → profile-migration
Version: 3.1 → 1.9.2 Branch

Comment 14

7 years ago
Oh, dang. Taking.
Assignee: nobody → ben.bucksch
Whiteboard: [gs]
(Assignee)

Comment 15

7 years ago
Ben, would you be able to have a patch of this by/on Monday? I'd like it in the respin for 3.1.2. If you can't I may be able to work on it, but would like to know roughly how you were thinking of fixing it.

Comment 16

7 years ago
mark, my plan was to introduce a new pref "something.migrated" which is set to true after the migration code set the autoMethod pref. It would be checked only if we found useSecAuth and friends and directly before writing the migrated authMethod, so that we don't need it in new profiles created in 3.1, only in migrated profiles.
(Assignee)

Comment 17

7 years ago
Created attachment 462173 [details] [diff] [review]
Fix and unit test

Based on Ben's suggestion this implements the migrated option per server that requires it.

I've gone for a migrated pref that has integer values, I'm not sure if we'd ever use them, but we at least can re-use it if we deem necessary.

Asking review from David, as I'd like to get this in asap to start 3.1.2, but also asking feedback from Ben to get his thoughts.
Assignee: ben.bucksch → bugzilla
Status: NEW → ASSIGNED
Attachment #462173 - Flags: superreview?(bienvenu)
Attachment #462173 - Flags: review?(bienvenu)
Attachment #462173 - Flags: feedback?(ben.bucksch)

Updated

7 years ago
Attachment #462173 - Flags: superreview?(bienvenu)
Attachment #462173 - Flags: superreview+
Attachment #462173 - Flags: review?(bienvenu)
Attachment #462173 - Flags: review+

Comment 18

7 years ago
Comment on attachment 462173 [details] [diff] [review]
Fix and unit test

Thanks, Mark, for the patch. Sorry for not providing it myself fast enough - it would have been my duty.

Patch is almost exactly what I had in mind, yes. r=BenB. Thanks!
Attachment #462173 - Flags: feedback?(ben.bucksch) → feedback+

Updated

7 years ago
Attachment #462173 - Flags: review+
(Assignee)

Comment 19

7 years ago
Comment on attachment 462173 [details] [diff] [review]
Fix and unit test

a=Standard8 for 3.1.2, as this is low risk and has good unit tests.
Attachment #462173 - Flags: approval-thunderbird3.1.2+
(Assignee)

Comment 20

7 years ago
Checked in on trunk and branches for 3.1.2:

http://hg.mozilla.org/comm-central/rev/654926c4dc9c
http://hg.mozilla.org/releases/comm-1.9.2/rev/f928d045509d
http://hg.mozilla.org/releases/comm-1.9.2/rev/33cfe20ec166
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
status-thunderbird3.1: --- → .2-fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.2a1
I just updated to 3.1.2 and on already migrated profile I find that changing Authentication method from 'Any secure method (deprecated)' to 'Normal' still doesn't stick on restart. Is that expected ?
You need to log in before you can comment on or make changes to this bug.