Async visits could be handled after a sync API that removes pages (like clearHistory)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: mak, Unassigned)

Tracking

({privacy, regression})

Trunk
privacy, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Since clearHistory removes pages synchronously (but visits async), and visits addition is now async, if we quickly add a visit and immediately call clear history, it can end up being registered after clear history.

This is rarely a problem in real usage since users are not so fast, but the issue is visible in tests. Similar issues could be visible with RemoveVisitsXXX and RemovePagesXXX APIs.
We need either to find a way to kill related tasks in adding visits or to make all pages removals APIS async.
(Reporter)

Updated

8 years ago
Blocks: 575132
hm, where in the async api bug dependency tree should this be?
(Reporter)

Updated

6 years ago
No longer blocks: 560198
(Reporter)

Updated

6 years ago
Depends on: 834545
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.