Closed Bug 580461 Opened 9 years ago Closed 9 years ago

WAV buffering logic doesn't kick in

Categories

(Core :: Audio/Video, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla5

People

(Reporter: cpearce, Unassigned)

References

Details

If we're receiving a WAV file at a rate less than we need to play it, nsWaveDecoder's buffering logic doesn't kick in.

STR:
1. Get a rate controlled web server and a large WAV file (for example http://pearce.org.nz/video/zurie-piratesxaimusremix.wav ).
2. Serve said large WAV file using a rate less than the bitrate of the file.
3. WAV's audio element switches between readyStates HAVE_CURRENT_DATA and HAVE_FUTURE_DATA and plays audio in stops and starts. The nsWaveDecoder doesn't switch into a buffering state and buffer a large chunk of data.
Bug 635649 refactors the wave backend to use the nsBuiltinDecoder code. This should either fix this bug, or make it generic for all backends. Will retest when patch lands.
Depends on: 635649
Bug 635649, the wave backend refactoring, has landed. nsWaveDecoder no longer has specific buffering logic for that backend. If the problem still occurs in the generic code shared amongst all backends please raise a bug for that.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
I cannot reproduce this -- VERIFIED FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.