Websites with javascript image transitions makes the system unresponsive

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Nathanael Noblet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.4) Gecko/20100622 Fedora/3.6.4-1.fc13 Firefox/3.6.4

When visiting the url http://www.shopthevillage.ca on linux, the system becomes unresponsive.

I should note that FF running on Windows XP, within a VirtualBox instance on linux does not suffer from the same issue.

I've tried all versions of Firefox (including 4b1)

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.shopthevillage.ca
2.
3.
Actual Results:  
System comes to a crawl until I can finally close the tab.

Expected Results:  
Banner images transition smoothly.
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 242364
From bug 242364 comment 13:

(Quad Core, 4G RAM, ATI 4670).
 We've isolated the problem to changing opacity on a dynamically
scaled images. Our test site is http://www.shopthevillage.ca/ if we remove the
scaling the transitions are smooth and performance is as expected. Otherwise
during a transition the system is unresponsive for a *long* time. I've tried FF
4B1 with the same effect.
Status: RESOLVED → REOPENED
Component: General → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Resolution: DUPLICATE → ---
Scaling is done by the X11 graphics drivers so is driver dependent.

Are you using the radeon driver from xf86-video-ati with kms?
This sounds like
https://bugs.freedesktop.org/show_bug.cgi?id=27139

We can work around that by using EXTEND_PAD instead of EXTEND_NONE.  (i.e. undo
our workarounds for bad extend pad.)
Bug 422179 will switch back to extend pad with upscaling.
I think we should also use extend pad for downscaling as GL-supporting video
cards are more likely to support extend pad than extend none.

See also bug 581797 comment 9 and subsequent.
(Reporter)

Comment 4

7 years ago
Yes we are using ATI hardware. I will have to double check if we have similar behaviour with an nvidia card, I think it was similar, though perhaps not as noticeable.
"glxinfo | grep OpenGL" will indicate the particular driver used.
I'm interested to hear whether you see similar issues with other drivers.
(Reporter)

Comment 6

7 years ago
I can confirm that with an intel card, this behaviour is not happening.

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) IGDNG_M GEM 20100328 2010Q1 
OpenGL version string: 2.1 Mesa 7.8.1
OpenGL shading language version string: 1.20
OpenGL extensions:
It's usually possible to work around driver bugs, but in this case I don't think we should. We're moving towards Skia, and some point we may also offer a software-only Cairo path, so this will rapidly become not-an-issue.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.