Closed Bug 580644 Opened 11 years ago Closed 7 years ago

ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window...

Categories

(Core :: IPC, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1014673

People

(Reporter: davidb, Unassigned)

References

(Blocks 1 open bug)

Details

STR:

1. Launch FF and go to http://www.rtve.es/
2. Launch "Inspect Objects" (part of MS Windows 7 SDK - Tools)
3. Click on one of the videos to play it.

Note 61 looks like WM_GETOBJECT:
{"WM_GETOBJECT",                        0x003D}

You should see assertions similar to:

++DOCSHELL 10862180 == 14
++DOMWINDOW == 39 (0E4CA208) [serial = 51] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(chromeWindow) failed: file c:/Users/davidb/moz/mozilla-central/content/base/src/nsFrameLoader.cpp, line 18
86
WARNING: Subdocument container has no frame: file c:/Users/davidb/moz/mozilla-central/layout/base/nsDocumentViewer.cpp, line 2396
++DOMWINDOW == 40 (0DF016E8) [serial = 52] [outer = 0E4CA1D0]
###!!! ASSERTION: Can't create document accessible!: 'docAcc', file c:/Users/davidb/moz/mozilla-central/accessible/src/base/nsAccD
ocManager.cpp, line 351
++DOMWINDOW == 41 (108FA570) [serial = 53] [outer = 1082CBB0]
++DOMWINDOW == 42 (108FA718) [serial = 54] [outer = 0E4CA1D0]
WARNING: NS_ENSURE_TRUE(hWnd) failed: file c:/Users/davidb/moz/mozilla-central/accessible/src/msaa/nsAccessibleWrap.cpp, line 1690

###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 263430 ("MozillaWindowClass"), sendi
ng it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/Windows
MessageLoop.cpp, line 318
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 263430 ("MozillaWindowClass"), sendi
ng it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/Windows
MessageLoop.cpp, line 318
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 263430 ("MozillaWindowClass"), sendi
ng it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/Windows
MessageLoop.cpp, line 318
WARNING: Bad accessible tree!: file c:/Users/davidb/moz/mozilla-central/accessible/src/base/nsAccessible.cpp, line 2821
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 853546 ("GeckoPluginWindow"), sendin
g it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/WindowsM
essageLoop.cpp, line 318
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 853546 ("GeckoPluginWindow"), sendin
g it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/WindowsM
essageLoop.cpp, line 318
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 853546 ("GeckoPluginWindow"), sendin
g it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/WindowsM
essageLoop.cpp, line 318
###!!! ASSERTION: Received "nonqueued" message 61 during a synchronous IPC message for window 853546 ("GeckoPluginWindow"), sendin
g it to DefWindowProc instead of the normal window procedure.: 'Error', file c:/Users/davidb/moz/mozilla-central/ipc/glue/WindowsM
essageLoop.cpp, line 318
--DOMWINDOW == 41 (0E4CB0F0) [serial = 32] [outer = 0E4CB260] [url = about:blank]
--DOMWINDOW == 40 (0E4CB298) [serial = 31] [outer = 00000000] [url = about:blank]

I discovered this assertion while investigating a vendor reported screen reader hang issue (Jaws). It might be related.
Jim, any ideas?
We might want to go back and look at the issues mentioned in comments 19 and 20 there. Those don't sound like issues with the changes surkov made in that try build. That bug seems to have wrapped up a bunch of issues. We can fire up the discussion there again if you like.
One of the things these readers can do is disable ipc plugins in our prefs. That would avoid any issues related to the error you're seeing here.
(In reply to comment #2)
> See bug 599814.

Yeah I was looking at that bug just before coming over here again :)  Discussing there is fine with me. The disable ipc plugins workaround is fine for now; do we know how long that might be supported?
(In reply to comment #5)
> (In reply to comment #2)
> > See bug 599814.
> 
> Yeah I was looking at that bug just before coming over here again :) 
> Discussing there is fine with me. The disable ipc plugins workaround is fine
> for now; do we know how long that might be supported?

Content processes in Fx 5.0 might throw a wrench in things. (bsmedberg is cc'd in on that other bug and can answer questions about that.) We should definitely have screen readers on the radar as part of that work.
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #2)
> > > See bug 599814.
> > 
> > Yeah I was looking at that bug just before coming over here again :) 
> > Discussing there is fine with me. The disable ipc plugins workaround is fine
> > for now; do we know how long that might be supported?
> 
> Content processes in Fx 5.0 might throw a wrench in things. (bsmedberg is cc'd
> in on that other bug and can answer questions about that.) We should definitely
> have screen readers on the radar as part of that work.

Content processes are our number one accessibility issue for 2011. I'm really hoping to have your help there. See: http://mindforks.blogspot.com/2010/11/asynchronous-accessibility.html). I'm going to meet with the Chromium guys (probably a few times) after FF4 ship and hopefully you can join in.
Saw this bug today testing click to play flash.
Blocks: 1052362
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014673
You need to log in before you can comment on or make changes to this bug.