Pre-filled "http://"" scheme shouldn't disappear when onChange/onBlur is triggered

VERIFIED FIXED in 3.1

Status

Input
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: stephend, Assigned: ryansnyder)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
STR:

1. Load http://input.stage.mozilla.com/en-US/sad
2. Click on the "Had an issue..." checkbox

Expected:

The pre-filled http:// shouldn't go away when onchange is fired

Actual:

It does, making the pre-filling not really all that useful...
(Reporter)

Updated

7 years ago
Duplicate of this bug: 597480
It's a HTML5 placeholder attribute. We could replace the placeholder text altogether and say "enter a URL here" or something. OOOOR we remove the placeholder altogether, make http:// a *value* instead of a placeholder, and then have to filter out all invalid submissions of just "http://" server-side.
Tired of dealing with this in the UI.  Committing a fix.  

https://github.com/fwenzel/reporter/commit/1d882d
Assignee: nobody → ryan
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.1
(Reporter)

Comment 4

7 years ago
Verified FIXED -- looks like 3.1 made it back into trunk now; thanks!
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.