JRE 6 freeze browsers and Java Control Panel Applet stops working!

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Antonello, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

Hello,
this is the second time I got this problem with Java JRE 6 ! First one was a month or two ago:

I have Java JRE 6 update 20 installed on a Windows 7 64bit ultimate. It was working...much time ago...then i found my browser (firefox, google chrome or IE8) was freezing when I open java application or test pages. I tried uninstalling it, cleaning the system with Revo Uninstaller, or CCleaner or JavaRA and reinstalling with no luck. The other problem is the same that user Mass8 had (http://forums.sun.com/thread.jspa?threadID=5372196&start=15&tstart=0)
...my java control panel applet is not working and give me this:
http://www.iouppo.com/lite/pics/df9b61008b5bf9de61a13d8bfa3ddad1.jpg

I tried disabling UAC, running JRE, starting Win7 in safe mode with network...but browser always freeze. It's not a true freeze, with CPU busy at 100% (cpu stays in idle) but it seems to wait for something. It's not a problem with video card driver on my machine, because I can start java control panel from command prompt...and without the noddraw switch, using this command:
javaw -Xbootclasspath/a:..\lib\deploy.jar -Duser.home="%HOMEDRIVE%%HOMEPATH%" com.sun.deploy.panel.ControlPanel

This was the description of my first time.....then I replaced my system with an Acronis image...and I used the system for sometimes....and Java was working until 3-4 days ago! So I did another image of the system with all things working.
Then this morning...I tried the java test page.....and surprise! It's not working anymore!
In these days I think I only disabled UAC and Account virtualization....maybe JAVA saves things there...and then when I disabled UAC (Windows7 deleted those folders and files) it can't find there anymore???? Who can help me?
I don't want to restore my image every month!
My system is 100% virus free and from the last image restoration I didn't visit suspicious sites and so on....I have antivirus and antispyware software...all is perfectly CLEAN. Any ideas or things to try? 

Reproducible: Always

Steps to Reproduce:
it always happens on my machine...and it's useless to uninstall and reinstall java
If you are having issues with the java control panel, this is obviously something you need to report to java. It is messed up way deeper than firefox can touch, and they need to take a look at it.
I can't see why this is a bug in Gecko that we can fix if your java installation breaks with every browser according to your report. It's not a problem with the plugin itself if even IE is freezing because they are using a different plugin (ActiveX).

I'm sorry but I have to mark this report invalid because this is nothing we could fix in our code. Please report it to sun/oracle.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.