Videos on hulu.com will not load using B2, but load on trunk

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({relnote})

unspecified
relnote

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [4b2][user agent], URL)

(Reporter)

Description

7 years ago
Seen while running Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

STR:
1. Load the video in the URL or any hulu.com video from the front page.
2. I get a spinning loading icon and the video never loads.

I have tried on three separate Macs in the lab -> 10.6, 10.5 and 10.5 PPC machine all with the same results. The same video plays and loads fine using both Safari on Chrome on the 10.6 machine.

Videos play fine using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100721 Minefield/4.0b3pre so this seems to be confined to Beta 2.

Comment 1

7 years ago
I get the same "spinning loading icon" on windows 7.   using this URL to test: http://www.hulu.com/watch/148113/family-guy-meeting-quagmires-dad

Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Shockwave Flash 10.1.53.64
OS: Mac OS X → All

Comment 2

7 years ago
Does Hulu use HTML 5 video? I can't check as the content is not available from my country. If it doesn't and is using flash then this bug is in the wrong component.
(Reporter)

Comment 3

7 years ago
This happens on all three Windows machines in the lab as well.  Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2.

The Flash version on the Windows 7/Vista machine is Shockwave Flash Version: 10.1.53.64. 

On the Windows 7 machine, the same video plays fine using Chrome and IE.
OS: All → Mac OS X
(Reporter)

Comment 4

7 years ago
Moved to plugins, it uses Flash. Sorry for the noise.
Component: Video/Audio → Plug-ins
QA Contact: video.audio → plugins
(Reporter)

Updated

7 years ago
Summary: Videos on hulu.com will not load → Videos on hulu.com will not load using B2, but load on trunk
I also tried several other videos within Hulu, with no luck, using Vista. Youtube Vimeo videos work, though.
blocking2.0: --- → ?
(Reporter)

Updated

7 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 6

7 years ago
I spoke briefly to jst, who suggested adding roc to the bug.
FWIW, this gives instructions on you how to see Hulu from outside the US: 

http://www.reddit.com/r/canada/comments/8zjv7/instructions_on_how_to_watch_thedailyshowcom/
Did this work in beta1? Can we get a regression range? The bonus of finding the target is you get to watch a lot of Family Guy.
blocking2.0: ? → betaN+
Keywords: regressionwindow-wanted
Sigh. It looks to be user agent sniffing at work. Hulu video doesn't work in 4b1 either, but it works in 3.7a6pre and works in 4b3pre as well.

When I use the user agent switcher addon (after forcing compatibility) and switch the default user agent to IE8, I can play videos in 4b2.
--> Tech Evangelism
Assignee: nobody → english-us
blocking2.0: betaN+ → -
Component: Plug-ins → English US
Keywords: regression, regressionwindow-wanted
Product: Core → Tech Evangelism
QA Contact: plugins → english-us
Whiteboard: [4b2] → [4b2][user agent]
Version: Trunk → unspecified
Keywords: relnote

Comment 11

7 years ago
Hulu is working for me in 4b2 without having to take any special measures
Hulu.com is working fine in FF 4.0 Beta 7

Comment 13

7 years ago
Hulu has not worked for me for about 4 months now. I just keep getting a prompt to load Flash. It works on my other mac but not this one with the newer version of Firefox.

Comment 14

7 years ago
Hulu has worked properly the entire time I've been testing Firefox 4, i.e., since Beta 6. I wonder if it's a profile issue.

Comment 15

7 years ago
Hulu.com is loading content from the #top just fine:

http://www.hulu.com/playlist/30329

Under Firefox 4 Beta 11 works fine; lo0ads the ad, loads the video.

Comment 16

6 years ago
I actually did have a problem with it more recently. It was when I upgraded to a Firefox 4.0b11pre (2011-29-01, I think. It was soon after bug 613915 was fixed). I thought it was an issue with the nightly, but when Firefox 4.0b11 came out, the problem remained. However, using a new copy of my profile from 4.0b10 (which should have been identical) worked perfectly.

So I think it might be something weird happening during the profile upgrade. Creating a new profile does seem to always fix it.

Comment 17

6 years ago
(In reply to comment #16)
> I actually did have a problem with it more recently. It was when I upgraded to
> a Firefox 4.0b11pre (2011-29-01, I think. It was soon after bug 613915 was
> fixed). I thought it was an issue with the nightly, but when Firefox 4.0b11
> came out, the problem remained. However, using a new copy of my profile from
> 4.0b10 (which should have been identical) worked perfectly.
> 
> So I think it might be something weird happening during the profile upgrade.
> Creating a new profile does seem to always fix it.

It's more than likely a profile problem then. When I installed b11 freshly, no problems (as I said above) it works fine, this is, of course, if using the default profile.

Comment 18

6 years ago
I ran into the problem in beta12. It actually seems to be related to IPC. If it's enabled, Hulu won't run. Since the change happens at restart, I hadn't noticed the correlation. The reason I wasn't having problems on earlier betas was that I had to turn IPC off due to Bug 613915.

Windows XP Firefox 4.0b12

Comment 19

6 years ago
Forgot: If necessary, I can attach my profile as a jar file.

Comment 20

6 years ago
Nevermind, I tracked it down to using NoSquint and having my page zoom set less than 100%. When dom.ipc.plugins.enabled is set to false, everything works properly. When it is set to true, it does not. Firefox's native zoom does not run into this problem.

I will inform the extension author of this problem. But, still it seems weird, as the extension is not, as far as I know, messing with the IPC at all.
Tested http://www.hulu.jp/watch/546915
Working for me. Firefox 32.
Closing.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.