Closed Bug 580920 Opened 11 years ago Closed 10 years ago

Acid 2 test fails in Fennec

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ahoza, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Android; Linux armv7l;en-US;rv:2.0b3pre) Gecko/20100721 Namoroka / 4.0b3pre Fennec/2.0a1pre

Face is distorted and shown partly in red when accessing link "Take The Acid2 Test"

Reproducible: Always

Steps to Reproduce:
1.Open Fennec and access: http://www.webstandards.org/files/acid2/test.html
2.Tap on the links available in the page

Actual Results:  
Links in http://www.webstandards.org/files/acid2/test.html appear as plain text.
When accessing "Take The Acid2 Test" link, smiley face is distorted and shown partly in red.

Expected Results:  
In the page displayed while accessing: http://www.webstandards.org/files/acid2/test.html, 2 links are available.
When opening them, "Hello World" text and a smiley face can be seen. The face has a yellow background with a black facial outline around it.

Device: HTC Desire A8181
OS: Other → Android
Hardware: x86 → ARM
Dont think we should be failing acid 2 tests.  blocking fennec 2.0?
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Yep, confirmed on build:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/20100802 Namoroka/4.0b3pre Fennec/2.0a1pre
tracking-fennec: ? → 2.0b1+
Also reproducible in desktop builds, both Fennec 1.1 and 2.0a1.
OS: Android → All
Hardware: ARM → All
The test fails in row 4-5, where two overlapping images must be offset by exactly one pixel to form a solid yellow area:
http://www.webstandards.org/action/acid2/guide/#row-4-5

This fails because of rounding issues when zoomed in or out.  (The test also fails when zoomed in desktop Firefox and other browsers.)  The test renders correctly some of the time when Fennec's zoom level is set to 100% (control+shift+z) or higher, but other times it still fails in the same place.
The default browsers in iOS 3.1 and Android 2.2 also fail the test.  The Acid2 guide says, *"Changing the zoom level, minimum font size, applying a fit-to-width algorithm, or making other changes may alter the rendition of the Acid2 page without this constituting a failure in compliance."*

I don't think this should block Fennec 2.0.
tracking-fennec: 2.0b1+ → ---
Summary: Acid 2 test fails on Android build → Acid 2 test fails in Fennec
Duplicate of this bug: 620809
tracking-fennec: --- → ?
Based on comment 5, Will Acid 2 ever pass on Fennec?  If not, should we disable out of litmus
I don't think we have any plans to make Acid 2 test on Fennec.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Disabling the Litmus test.
tracking-fennec: ? → ---
Flags: in-litmus+
You need to log in before you can comment on or make changes to this bug.