Closed Bug 580940 Opened 11 years ago Closed 10 years ago

[config] Add terra.es (Spain)

Categories

(Webtools :: ISPDB Database Entries, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Usul, Assigned: willyaranda)

Details

Attachments

(1 file, 3 obsolete files)

Wondering if terra.com is on the same config ?
Attached file NOT tested (obsolete) —
I have an account, waiting for instructions about how to test it
Assignee: nobody → willyaranda
Status: NEW → ASSIGNED
Ben, the username here is:

name+"."+domain

the line that should be in the conf file is

<username>%EMAILLOCALPART%.%EMAILDOMAIN%</username>

right?

because I'm getting a empty username while testing it (the other parameters seem ok)
Attachment #459728 - Flags: review?(ben.bucksch)
Guillermo, that's because the file is invalid (the XML exported from ISPDB app is broken). I'll attach a corrected one.

Guillermo, please try to find SSL-enabled configs, even if the ISP does not announce them. Ask hotline specifically for SSL, and insist on it. And search on the Internet for it.

Also, is there IMAP available?

What I see:
- SMTP mailhost.terra.es 25 works plain and with STARTTLS
- SMTP mailhost.terra.es 587 does not work
- SMTP mailhost.terra.es 465 SSL does not work
- POP3 pop3.terra.es 110 works plain, but not with STARTTLS
- POP3 pop3.terra.es 995 SSL does not work
- IMAP imap.terra.es 993 SSL does not work
- IMAP imap.terra.es 143 plain responds, but IMAP commands fail,
  e.g. "1 capability" gives "BAD"
- pop3.terra.es is same host as imap.terra.es

So, SMTP STARTTLS seems to work, and POP3 without SSL works, the rest fails.
(It is quite possible, though, that there are other hostnames where SSL is available. So, Guillermo, please do try to find SSL configs.)
Attachment #459728 - Attachment is obsolete: true
Attachment #461767 - Flags: feedback?(willyaranda)
Attachment #459728 - Flags: review?(ben.bucksch)
Attachment #461767 - Attachment is patch: false
Attachment #461767 - Attachment mime type: text/plain → text/xml
> Ben, the username here is: name+"."+domain
> the line that should be in the conf file is, right?
> <username>%EMAILLOCALPART%.%EMAILDOMAIN%</username>

FYI, yes, that's correct, and it's smart of you to have figured that out :)
- SMTP mailhost.terra.es 25 works plain and with STARTTLS

not other configuration is working


- POP3 pop3.terra.es 110 works plain, but not with STARTTLS

(but i'm unable to get it working)
> (but i'm unable to get it working)

You're saying the config does not work?

Can you try modifying the username to be the email address?
willyaranda: ping
I've tried to contact Terra to get more information, but I'm not getting any response.

Also, trying to modify the username didn't work, but I'm going to try now to test it with a recent TB build.
(In reply to comment #10)
> I've tried to contact Terra to get more information, but I'm not getting any
> response.
> 
> Also, trying to modify the username didn't work, but I'm going to try now to
> test it with a recent TB build.

Get them on the phone and say you are calling as a representative from mozilla that should help you get started.
*snicker*
XML Parsing Error: not well-formed
Location: http://mov.terra.es/servicios.aspx
Line Number 209, Column 99:
Ok, I've tried several configurations, and I'm having a good (but no secure) configuration:

Incoming:
IMAP:
Server: imap4.terra.es
Port: 143
User: {user}@terra.es
Security: none, plain text
"Identification method" (or something like that, it's the next option): "Password, sent insecurely" (or something like that, sorry!!)

The server doesn't work with STARTTLS or SSL/TLS

Outgoing:
SMTP:
Server: mailhost.terra.es
Port: 25
User: {user}@terra.es
Security: STARTTLS
"Identification method": Normal password.

Anyway, I'm getting ugly security messages while adding the server and when sending the first time too.
While sending the email, I'm getting:

1) error in the compose window

2) and then a focus in the main window to add the certificate to TB (the main problem is that the certificate expired in… 2004! really funny), but it seems it's a test (the common name is: localhost and the emisor is a "test"…)…

After adding the certificate and re-sending the email, everything is working, so I don't know if it's better to send without STARTTLS because it doesn't have this kind of problems, but I don't know about the security of STARTTLS.

Any ideas?
Given that IMAP server is not secured, I think it's best to leave SMTP insecure, too, given these problems.

Thanks for finding the right username form. full email address as username is pretty standard. The rest of the config matches the attached config, just that you have an IMAP server, that's great, too.

Could you please check pop3.terra.es as well, just to be sure?

I'll attach a new config.
Attached file Config, v3 (obsolete) —
Attachment #461767 - Attachment is obsolete: true
Attachment #493303 - Flags: review?(sancus)
Attachment #461767 - Flags: feedback?(willyaranda)
Attachment #493303 - Flags: review?(gozer)
But you have added:

<socketType>STARTTLS</socketType>

in SMTP protocol, is that correct?

pop3.terra.es is working without problems.
Attached file Config, v4
Oops, sorry. Thanks for catching.

And thanks for testing! :-)
Attachment #493303 - Attachment is obsolete: true
Attachment #493305 - Flags: review?(sancus)
Attachment #493303 - Flags: review?(sancus)
Attachment #493303 - Flags: review?(gozer)
Attachment #493305 - Flags: review?(gozer)
Attachment #493305 - Flags: review?(gozer) → review+
sancus review ping.
Comment on attachment 493305 [details]
Config, v4

Seems to work fine to my limited testing capacity~!
Attachment #493305 - Flags: review?(sancus) → review+
Tested today, and working. Check-in?
Commited SVN Revision 81718
FIXED

willyaranda, could you test it again once it appears on the server, please? Thanks.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Verified! Awesome, thanks!
server update times from svn are about 15 minutes I believe, in general, for all mozilla messaging web services.
Component: ispdb → ISPDB Database Entries
Product: Mozilla Messaging → Webtools
You need to log in before you can comment on or make changes to this bug.