Closed Bug 581072 Opened 10 years ago Closed 10 years ago

Timeouts fire too early if suspended and then resumed

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b3
Tracking Status
blocking2.0 --- beta3+

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

This is a regression from bug 558306.  I switched the sign on the subtraction when suspending timers, so instead of setting a positive delay we set a negative one, and then the timers fire too early, of course.

Fix coming up.
Duplicate of this bug: 581071
Blocks: 580880
Attached patch Fix + testSplinter Review
Attachment #459496 - Flags: review?(jst)
Attachment #459496 - Flags: approval2.0?
blocking2.0: --- → beta3+
Attachment #459496 - Flags: review?(jst)
Attachment #459496 - Flags: review+
Attachment #459496 - Flags: approval2.0?
Attachment #459496 - Flags: approval2.0+
Pushed http://hg.mozilla.org/mozilla-central/rev/308a5a2782b0
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b3
We should probably document the new API added here:

    3.16 +
    3.17 +  /**
    3.18 +   * Suspend/resume timeouts on this window and its descendant windows.
    3.19 +   */
    3.20 +  void suspendTimeouts();
    3.21 +  void resumeTimeouts();

on nsIDOMWindowUtils.
Keywords: dev-doc-needed
bz, you win bonus points for specifically listing the items that need documenting.

The new methods have been documented:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsIDOMWindowUtils
Well, without listing them the bug gave no idea of what the new stuff is, right?  ;)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.