If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Feature request: export Address Book is not in the product

VERIFIED DUPLICATE of bug 52045

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED DUPLICATE of bug 52045
17 years ago
13 years ago

People

(Reporter: marina, Assigned: chuang)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
- give a non-ascii name to AB;
Import a file with non-ascii name through the Import utility(File|Import);
//note: there is no data imported , all cards are blank

Comment 1

17 years ago
I don't have this problem when I import an address book with Ja filename.
All the cards in it (including non-ASCII cards) are displayed okay after 
importing.

Comment 2

17 years ago
Marina, please specify the actual name of the addressbook you tested, thanks.
Summary: No dat is imported when Address Book has a non-ascii name → No data is imported when Address Book has a non-ascii name
(Reporter)

Comment 3

17 years ago
i need to investigate this one , because it looks like it's not an i18n problem
but maybe an important of the renamed file.
(Reporter)

Comment 4

17 years ago
i was trying to re-import by renaming a mab file (because i don't see any way to
Export file from Nscp6) and this doesn't work. How are we saving an AB file in
nscp6?

Comment 5

17 years ago
Reassign to chuang.
Assignee: nhotta → chuang
(Assignee)

Comment 6

17 years ago
You can't rename a .mab file into a .ldif file and try to import it. The data 
format is totally different.  You can rename a .ldif into a different name 
(a.ldif to b.ldif) and import the ldif file.  
(Assignee)

Comment 7

17 years ago
One more thing, we don't have Export in 6.0 yet.  We can't save the address book 
into .ldif or .tab file.
(Reporter)

Comment 8

17 years ago
yes, .ldif is fine, it was mab that after renaming has a blank data, so it is as
designed??
(Reporter)

Comment 9

17 years ago
changed a component
Component: Internationalization → Address Book
Summary: No data is imported when Address Book has a non-ascii name → No data is imported when mab file is renamed
(Assignee)

Comment 10

17 years ago
.mab file is our database file for address book as .na2, .nab file in 4.x.  
Normal user should not rename or do something about it.  This is not a bug or 
design issue,  it's the same as we don't rename .na2 file and try to import it 
in 4.x.   Lack of Export is a missing feature,  you can file a bug for it.
(Reporter)

Comment 11

17 years ago
so i invalid this one and open another one for feature request?
(Assignee)

Comment 12

17 years ago
Either way is fine with me, change the summary or create a new bug.  QA can 
decide which way is better.
(Reporter)

Comment 13

17 years ago
changed the summary per our discussion to reflect the actual problem with saving
AB file 
Summary: No data is imported when mab file is renamed → Feature request: export Address Book is not in the product
(Assignee)

Comment 14

17 years ago

*** This bug has been marked as a duplicate of 52045 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
Verified as a duplicate of Bug 52045.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.