make chrome no longer works

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0.9, regression})

Trunk
fixed-seamonkey2.0.9, regression
Points:
---

Firefox Tracking Flags

(status1.9.2 .9-fixed, status1.9.1 .12-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
make chrome recursively invokes make realchrome. However the realchrome target is now conditional on the existence of a jar.mn file.
(Assignee)

Comment 1

7 years ago
Created attachment 459551 [details] [diff] [review]
Possible patch

I also considered moving the NO_DIST_INSTALL ifdef since it's an easier test.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #459551 - Flags: review?(me)
(Assignee)

Comment 2

7 years ago
Comment on attachment 459551 [details] [diff] [review]
Possible patch

Actually this fix applies pretty obviously to c-c rules.mk too (with offset).
Attachment #459551 - Flags: review?(bugspam.Callek)
Attachment #459551 - Flags: review?(me) → review+
Comment on attachment 459551 [details] [diff] [review]
Possible patch

rs+ for c-c based on khuey's r+ for m-c.
Attachment #459551 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 4

7 years ago
Pushed changeset b6e2a919b701 to mozilla-central.

Pushed changeset a0e75bd610cf to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

7 years ago
Comment on attachment 459551 [details] [diff] [review]
Possible patch

Seeking approval for all branches where this trivial build config regression is known to have landed. (Using f? instead of a?Tb3.x because I'm too lazy.)
Attachment #459551 - Flags: feedback?(bugzilla)
Attachment #459551 - Flags: approval1.9.2.9?
Attachment #459551 - Flags: approval1.9.1.12?

Comment 6

7 years ago
Comment on attachment 459551 [details] [diff] [review]
Possible patch

a=LegNeato for 1.9.2 and 1.9.1
Attachment #459551 - Flags: approval1.9.2.9?
Attachment #459551 - Flags: approval1.9.2.9+
Attachment #459551 - Flags: approval1.9.1.12?
Attachment #459551 - Flags: approval1.9.1.12+
(Assignee)

Comment 7

7 years ago
Pushed changeset c3643db869bd to releases/mozilla-1.9.2

Pushed changeset ca834d8c9c54 to releases/mozilla-1.9.1
status1.9.1: --- → .12-fixed
status1.9.2: --- → .9-fixed
Attachment #459551 - Flags: feedback?(bugzilla)
(Assignee)

Comment 8

7 years ago
Pushed changeset 69369e04b3bf to releases/comm-1.9.2

Pushed changeset 823d07f99704 to releases/comm-1.9.1

(I actually got a=Standard8 over IRC a couple of weeks ago)
Keywords: fixed-seamonkey2.0.8
(In reply to comment #8)
> Pushed changeset 69369e04b3bf to releases/comm-1.9.2

Backed this out in changeset 015dd7372a09 due to complete bustage on 1.9.2.
You need to log in before you can comment on or make changes to this bug.