If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Implement fullscreen API (for Video, perhaps for others)

RESOLVED DUPLICATE of bug 545812

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 545812
7 years ago
2 years ago

People

(Reporter: vlad, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

One of the big missing pieces for video is a JS-visible fullscreen API that players can incorporate into their own UI (e.g. Youtube not having to do lame resize-the-browser-window-kinda-sorta-fullscreen).  roc has some ideas on how this should work; I think this is a pretty big requirement for getting Flash parity on video with Firefox 4.

Filing this in Video, though it would be nice to reuse most of the code for a generic page fullscreen API.
Status: NEW → RESOLVED
blocking2.0: ? → -
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545812
You need to log in before you can comment on or make changes to this bug.