Closed Bug 581491 Opened 11 years ago Closed 11 years ago

Clicking on a text field fails to focus the field under certain circumstances

Categories

(Camino Graveyard :: HTML Form Controls, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: krag, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.8pre) Gecko/20100709 Camino/2.1a1pre (like Firefox/3.6.8pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.8pre) Gecko/20100709 Camino/2.1a1pre (like Firefox/3.6.8pre)

not only this URL but many others... the text field does not become active with clicking on it, so I usually go to the address bar and hit the tab from there to get to the "comments" section of websites, just clicking on the text field in the form does nothing to activate it and place the cursor there.

Reproducible: Sometimes

Steps to Reproduce:
1.happens on half of the websites.
2.
3.
Can you be a little more specific about what else might be going on when this happens? For instance, can you reproduce the problem by merely opening the above link in a new (foreground) tab and then waiting for the page to load completely?

Which text field on the example URL is the problem? (I see at least two.) Or are both equally affected?

Does switching to another application, then back to Camino, while that page is the foreground tab in the frontmost window allow you to then focus the affected text field?
Summary: not only this URL but many others... the text field does not become active with clicking on it, so I usually go to the address → Clicking on a text field fails to focus the field under certain circumstances
I'll do more research and post the web pages I experience this with, there has been a few so far.
I haven't seen it at this specific URL, but I *have* seen something very similar to this, where focus can't be applied to a text field in the content area without either switching among existing tabs or opening a new tab and closing it.

A number of other people have noted the same thing with 2.1 nightlies, and at least one person has reported similar behaviour with either 2.0.4 or a 2.0.x nightly (I forget which).

We really need to figure this out.
See also bug 600187.
Blocks: 600483
krag, can you see if bug 600187 sounds like what you're experiencing? If so, please feel free to change the resolution on this to DUPLICATE (of that bug). I'm gonna close this as INCOMPLETE since we don't have any answers to comment 1, but we strongly suspect this is just another report of that bug.

cl
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.