When a quicksearch includes the "content" field, it is limited to 200 bugs

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Assigned: Frédéric Buclin)

Tracking

3.6.1
Bugzilla 3.6
Bug Flags:
approval +
approval4.0 +
approval3.6 +
blocking3.6.2 +

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL+comp%3Aparser+crash
200 bugs

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL+comp%3Aparser+summary:crash
327 bugs

Updated

7 years ago
Flags: blocking3.6.2+
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503806
(Assignee)

Updated

7 years ago
Target Milestone: Bugzilla 3.6 → ---

Comment 2

7 years ago
That's not a duplicate of that bug. That bug was actually about the potential of doing those things. I never intended for it to happen until we resolved the question in that bug (which was pretty much answered "no" by the comments).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

7 years ago
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Comment 3

7 years ago
All we have to do is to remove the 2nd line of:

elsif ($fulltext) {
    $query .= " " . $dbh->sql_limit(FULLTEXT_BUGLIST_LIMIT);

Or maybe it only makes sense to limit the query to 200 results when using the Simple Search form (as it's only used by newbies). What do you think? In that case, we could replace the condition by:

elsif ($cgi->param('simple_search')) {
    ....
Status: REOPENED → NEW
Version: unspecified → 3.6.1

Comment 4

7 years ago
I suppose we could just remove the limit entirely, no? I don't think Simple Search is used all that often.
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
> I suppose we could just remove the limit entirely, no? I don't think Simple
> Search is used all that often.

But how relevant are bugs above the 200th position? Do we really want to show more bugs than that to those using the Simple Search form?

Comment 6

7 years ago
I think it's hard to say. What I *do* know is that we want to make the Simple Search form into a quicksearch box (and then probably just relevance sort it) so they probably should start both behaving the same way.

I think there isn't too much harm in showing people bugs above the 200th position, so we might as well do it, since we're pretty sure that quicksearch people want to see more than 200 bugs.
(Assignee)

Comment 7

7 years ago
Created attachment 461949 [details] [diff] [review]
patch, v1
Assignee: query-and-buglist → LpSolit
Status: NEW → ASSIGNED
Attachment #461949 - Flags: review?(mkanat)

Comment 8

7 years ago
Comment on attachment 461949 [details] [diff] [review]
patch, v1

Looks good to me.
Attachment #461949 - Flags: review?(mkanat) → review+

Comment 9

7 years ago
Bye bye premature optimization! :-)
Flags: approval4.0+
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 10

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified buglist.cgi
modified Bugzilla/Constants.pm
modified template/en/default/global/messages.html.tmpl
Committed revision 7411.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified buglist.cgi
modified Bugzilla/Constants.pm
modified template/en/default/global/messages.html.tmpl
Committed revision 7355.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified buglist.cgi
modified Bugzilla/Constants.pm
modified template/en/default/global/messages.html.tmpl
Committed revision 7150.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.