Closed Bug 581734 Opened 9 years ago Closed 7 years ago

mochitest-chrome persistent failure (+ intermittent elsewhere): toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.

Categories

(Core :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: smontagu)

References

Details

(Keywords: intermittent-failure, Whiteboard: [win7])

Attachments

(1 file)

On the Windows 7 mochitest-browser-chrome unit test machines, we see the following failure every time:

2716 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.

This was previously being tracked on bug 565504, but that bug was about a different problem with this test (it was intermittent rather than persistent, and an exception rather than a timeout).
Summary: Windows 7: toolkit/content/tests/chrome/test_bug558403.xul | Test timed out. → Windows 7 mochitest-chrome persistent failure: toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.
And, in general, you can find the logs on the Win7 Mo(oth) line on:
http://tests.themasta.com/tinderboxpushlog/?noignore=1

Simon, could you have a look at this?
Just a reminder that this is one of the last oranges that is stopping from running unit tests on the minis instead of the builders.
Reaching that point will help us to move the load of unit test jobs to the minis and be able to move more machines to the try pool were the wait times are pretty bad.
Any progress in here will help many so thanks in advance!
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281439773.1281440861.12324.gz
WINNT 5.2 mozilla-central opt test mochitest-other on 2010/08/10 04:29:33

s: mw32-ix-slave17
SSLTUNNEL(00C25DD0): polling flags csock(0)=--, s7612 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
This isn't just windows 7 anymore.  It's happening intermittently elsewhere.
Summary: Windows 7 mochitest-chrome persistent failure: toolkit/content/tests/chrome/test_bug558403.xul | Test timed out. → Windows 7 mochitest-chrome persistent failure (+ intermittent elsewhere): toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.
I just got a try run:
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1281509794.1281512011.32140.gz
where the error was instead:

7612 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - s1 is not defined at chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul:80
JavaScript error: chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul, line 80: s1 is not defined
7613 INFO SimpleTest finished chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug558403.xul in 2643ms

I mention it in case it might shed light on what is happening.
Like comment 20 said it doesn't look to be win7 only.
Summary: Windows 7 mochitest-chrome persistent failure (+ intermittent elsewhere): toolkit/content/tests/chrome/test_bug558403.xul | Test timed out. → mochitest-chrome persistent failure (+ intermittent elsewhere): toolkit/content/tests/chrome/test_bug558403.xul | Test timed out.
Sayrer this is the other test that we would need to be disabled besides bug 562955.

Thanks
There's something very strange here: http://hg.mozilla.org/mozilla-central/rev/125ccddf2fc3 made the test register a non-existent manifest: chrome://mochikit/content/chrome/toolkit/content/tests/chrome/rtlchrome/righttoleft.manifest as opposed to chrome://mochikit/content/chrome/toolkit/content/tests/chrome/rtlchrome/rtl.manifest.

If I change that back locally (where I'm not seeing the timeout) the test starts failing as reported in bug 581239.
Attached patch Remove the testSplinter Review
I confirmed that even where the test doesn't time out, it's not currently testing anything anyway, since it passes even if I back out the fix to bug 558403.

It's also rather fragile -- there are at least two other bugs on intermittent failures with it -- so I'd rather just remove it and write a completely new test than try to fix it.
Assignee: nobody → smontagu
Keywords: checkin-needed
(In reply to comment #31)
> Created attachment 465373 [details] [diff] [review]
> Remove the test
> 
> I confirmed that even where the test doesn't time out, it's not currently
> testing anything anyway, since it passes even if I back out the fix to bug
> 558403.
> 
> It's also rather fragile -- there are at least two other bugs on intermittent
> failures with it -- so I'd rather just remove it and write a completely new
> test than try to fix it.

sayre/simon: who should review this patch, and when can this patch be landed? 

(sorry for the ping, but its blocking us disabling tests on builders, which would help with infrastructure load during crunch time, so is urgent.)
Comment on attachment 465373 [details] [diff] [review]
Remove the test

I will check this in on TM to see that it works.
Attachment #465373 - Flags: review+
Blocks: 438871
Test removed in comment 39
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [win7][orange] → [win7]
You need to log in before you can comment on or make changes to this bug.