Status

P3
enhancement
VERIFIED DUPLICATE of bug 53462
18 years ago
14 years ago

People

(Reporter: BenB, Assigned: cls)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If jar packaging is enabled, the individual files are still copied to dist/bin.
Consequently, they are also packaged. This is a space waste for normal users.
Workaround: Manually eelete the dirs under dist/bin/chrome before packaging for
distribution. Would be nicer, if we had a flag not to copy them there in the
first place. RFE: Add it.

Comment 1

18 years ago
Ben: I don't think the process works like you think. We copy the files to dist
_in order to_ zip them up. We could delete them after zipping, but I don't
really see why that's necessary, and it could lead to other problems.

Besides, the "normal users" you're talking about aren't really normal -- they're
early adopters who take tarballs complete with test programs and all sorts of
extra cruft. I'd say this is pretty low priority.
(Reporter)

Comment 2

18 years ago
> We copy the files to dist _in order to_ zip them up.

Oh, ic. Then my suggestion is to add the option to delete them shortly before
packaing, in xpinstall/package/Makefile.in et al..

warren, how do I best get the list of packages from within a Makefile?

> Besides, the "normal users" you're talking about aren't really normal

No, I was speaking about really normal users - users of a Mozilla distributions.
This bug would make creating such a distribution a bit easier.

Comment 3

18 years ago
The build team didn't want to tweak anything put into dist by the build process
before zipping up. They don't want to introduce more complexity and potential
problems.

Normal users are ones who take our beta bits, with installers, etc. People
taking tarballs are already signed up for giving up at least a gigabyte of disk
space. What's a few meg more more between friends?
(Reporter)

Comment 4

18 years ago
> Normal users are ones who take our beta bits, with installers, etc.

There is not only Netscape. This bug is about making life easier for competitors
of Netscape. That's the whole purpose of mozilla.org, not?

What problem could it cause to remove left-overs from the build process in the
dist dir of an BUILD_OFFICIAL build tree?

Comment 5

18 years ago
isn't this a dup of bug 53462?
(Reporter)

Comment 6

18 years ago
yes.

*** This bug has been marked as a duplicate of 53462 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified Dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.