nsNavHistory::InitDBFile permanent fail on child process

RESOLVED DUPLICATE of bug 576518

Status

()

Toolkit
Places
RESOLVED DUPLICATE of bug 576518
8 years ago
4 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Bunch of NS_ERROR_FAILURES happen, because nsNavHistory::InitDBFile
fail to get NS_GetSpecialDirectory(NS_APP_USER_PROFILE_50_DIR,...

What should we do about it? Disable nsNavHistory or add ServiceDirProvider to content process... ?

Comment 1

8 years ago
Haven't you filed this bug twice already? We should not have a nsNavHistory in the content process! Please dup this bug to one of the ones already filed.
Whiteboard: DUPEME

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576518
(Reporter)

Comment 3

8 years ago
> the content process! Please dup this bug to one of the ones already filed.
Oh, sorry

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.