JavaScript and D2D conflict ( resulting the poor performance -- either JS or D2d-- when both are activated.

RESOLVED DUPLICATE of bug 576169

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 576169
7 years ago
7 years ago

People

(Reporter: lukaswrites.bugzilla, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b2], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

D2D performance on Firefox Beta 2 and the latest trunk ( firefox-pre-b3) seem to be somehow 'affected' by the javascript. In the beta 1 , the d2d performance is greater than JavaScript performance. But, in beta2 and beta3pre, the JavaScript performance is greater than the d2d performance. I think that there's conflict between them.

Reproducible: Always

Steps to Reproduce:
1.open firefox beta2 or beta3pre (as of 25 july '10), activate d2d capability through about:config
2.open the url above.
3.make the fish become 250 in number -- click the link on the right side.
Actual Results:  
poor performance. Beta 2 and pre3 only runs at +- 27 fps (note : sunspider test's result is +- 600)

Expected Results:  
should be as great as beta 1. Beta 1 runs constantly at 60 fps, but the sunspider test's result is only > 800 

I just think that there's conflict between the JavaScript and d2d, when both are activated.
(Reporter)

Updated

7 years ago
Whiteboard: [4b2]
Version: unspecified → Trunk
This regressed with clipping fixes and will be addressed with bug 576169.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576169
You need to log in before you can comment on or make changes to this bug.