Feature Request: Ability to Merge/Flatten Bookmark Folders

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: Mike Harris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

I would like to (humbly) ask ... nay, probably "beg" is a more appropriate verb ... the Firefox development team to consider the development of a "Merge" bookmark feature in the Bookmark Organizer.  Personally, I see the implementation as very low-profile UI -- simply a "merge" contextual item that would appear when more than one folder is selected within the Bookmark Organizer.

Once selected, it would merely merge the contents of the selected bookmark folders.

This can be accomplished somewhat by a cut-and-paste of bookmark items, but that process becomes ornery and annoying when attempting to merge, say, 10-15 bookmark folders.  Being able to select the folders, right-click and pick a "merge" contextual item would be quite convenient.

(How do I end up with 10-15 bookmark folders?  I tend to bookmark all tabs open in a window before closing a Firefox window for one reason or another -- whether I am shifting to another subject or closing down for lunch or for the night.)

Reproducible: Always
This would be awesome for an add-on, since the use-case is particular and I don't see most of our users in need of such a feature
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.