If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Html comments <!-- don't hide the text inside

RESOLVED DUPLICATE of bug 570309

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 570309
7 years ago
7 years ago

People

(Reporter: julien, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 AlexaToolbar/alxf-1.54 Firefox/4.0b2 GTB7.1 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 AlexaToolbar/alxf-1.54 Firefox/4.0b2 GTB7.1 ( .NET CLR 3.5.30729)

The html comments <-- don't works
The text inside the comments is still displayed on the page

Reproducible: Always

Steps to Reproduce:
1.Just read a page with the <!-- text --> inside the code of this page
Actual Results:  
<!-- text hidden inside -->
will display :
text hidden inside

Expected Results:  
nothing appear

works with firefox 3 and others
(Reporter)

Updated

7 years ago
Summary: Html comments <-- don't hide the text inside → Html comments <!-- don't hide the text inside
(Reporter)

Comment 1

7 years ago
in fact the <!-- hide the text but Firefox 4 tanslate -- > as a --> so close too soon the comment code (see example below)

<a class="bn" href='articles.php?manage=11'>Type</a>
			<br /> --- > <a class="bn" href='articles.php?manage=1'>Cat├ęgories</a>
			<br /><br />
                </td>
              </tr>
              -->

will be displayed

example :
 <!--
              <tr> 
                <td valign="top"><img src="charte/charte_bn_puce.gif" width="5" height="9" align="absmiddle"></td>
                <td><a class="bn" href='#'>title</a>
			<br /> --- > <a class="bn" href='articles.php?manage=11'>Type</a>
			<br /> --- > <a class="bn" href='articles.php?manage=1'>Cat├ęgories</a>
			<br /><br />
                </td>
              </tr>
              -->


hope i am enough clear

Comment 2

7 years ago
This is an issue with the new HTML5 spec. "Fixed" in the next beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570309
You need to log in before you can comment on or make changes to this bug.