App Tabs: Undo close tab leaves app tab and normal tab overlapping

RESOLVED DUPLICATE of bug 579869

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 579869
8 years ago
8 years ago

People

(Reporter: Andrew Rose, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 (.NET CLR 3.5.30729)

If you close an app tab (e.g. with Ctrl-W or my middle-clicking) and then choose the "Undo close tab" menu option, the restored app tab opens on the left but doesn't push the other tabs far enough to the right.  As a result, the app tab and the first real tab end up overlapping each other.

Reproducible: Always

Steps to Reproduce:
1. Open a GMail tab
2. Open another tab
3. Convert the GMail tab to an App Tab
4. Close the GMail tab by middle-clicking or switching to it and pressing Ctrl-W
5. Right-click the surviving tab and choose "Undo close tab" from the context menu.
Actual Results:  
GMail tab appears but is overlapped with the other tab.  The other tab moves a little to the right but not far enough.

Expected Results:  
The normal tab is pushed far enough to the right that the app tab and the normal tab don't overlap.
(Reporter)

Comment 1

8 years ago
Created attachment 460814 [details]
Screenshot of bug

I've attached a screenshot of the bug, because it probably isn't all that clear from the description.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579869
You need to log in before you can comment on or make changes to this bug.