Closed Bug 582536 Opened 11 years ago Closed 5 years ago

Only sync prefs that have been changed from the default

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 744626
Tracking Status
blocking2.0 --- -

People

(Reporter: philikon, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [sync:preferences])

Mobile and desktop Firefox may have different default preferences for certain things, or Firefox may change the default setting from one version to the next. In both cases you wouldn't want Sync to interfere with the default. It should just sync changes from the default preferences.
It might make sense to do this change in one go with bug 560580 since that would imply a new storage version for the pref engine.
Blocks: 571897
Flags: blocking-fx-sync1.5?
Flagging for in-testsuite. If positive, Will have to mute this test until this bug is fixed.
Flags: in-testsuite?
blocking2.0: --- → ?
Another wart we might want to fix as part of this would be to sync the prefs engine's settings, IOW all services.sync.prefs.sync.* preferences. Right now you have to make changes to those on all clients.
Why should this block the release?
blocking2.0: ? → -
Flags: in-testsuite?
Flags: blocking-fx-sync1.5?
Flags: blocking-fx-sync1.5-
Target Milestone: --- → Future
we have considered this and think we should hold off on this until after sync 2.0.
Whiteboard: [sync:preferences]
Target Milestone: Future → ---
Blocks: 645259
Bug 744626 landed support for ensuring we do the right thing with default preferences.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 744626
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.