Closed Bug 582583 Opened 9 years ago Closed 9 years ago

Expose a small, simple UI for 'Undo Closed Tab'

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: mfinkle, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Bug 579361 added the backend changes to support 'Undo Closed Tab' and implements a simple CTRL+SHIFT+T shortcut key to undo the last closed tab. We should consider making a small UI to expose the feature too.
Needs a design
Keywords: uiwanted
I made a design suggestion at the session-store planning-page:  https://wiki.mozilla.org/Mobile/Projects/SessionStore
(In reply to comment #2)
> I made a design suggestion at the session-store planning-page: 
> https://wiki.mozilla.org/Mobile/Projects/SessionStore

Jan - The awesomescreen is changing. See https://wiki.mozilla.org/Mobile/Projects/AwesomeScreen2.0

Your design might not fit after those changes.
(In reply to comment #3)
You are right, it would not fit the way it was planned. But: I can't think of a better place than the screen that you get after you open a new tab: It does not add anything to the chrome and it would be in the right place since the user will open a new tap to reopen the page anyway (or is on the awesomescreen since he closed the last page)
I can think of it being integrated in the history view - the function is anyway a kind of simple history. Actually I suppose "recently closed" as more important (in terms of "being actually used") as the "full" history. I remember that Madhava and Aza have had a discussion about history at the beginning of the project, in which was mentioned that history is hardly used even on desktop computers.
I like the idea - visibility and mapping are decent.
tracking-fennec: --- → ?
Flags: in-testsuite?
Flags: in-litmus?
tracking-fennec: ? → 2.0+
Final visual treatment in the Android theme mockups.
Keywords: uiwanted
Attached patch PatchSplinter Review
The patch implement Madhava's mockup except that the closed tab always stays on the bottom-left side of the tabs bar.
Attachment #479736 - Flags: review?(mark.finkle)
Duplicate of this bug: 548633
Assignee: nobody → 21
tracking-fennec: 2.0+ → 2.0b2+
Comment on attachment 479736 [details] [diff] [review]
Patch

>+#tabs [anonid="tabs-children"] documenttab:only-child > .documenttab-container > .documenttab-close-container > .documenttab-close {
>+  display: none;
>+}
>+
>+
> #tabs-controls {

extra space and that CSS selector is crazy long
Attachment #479736 - Flags: review?(mark.finkle) → review+
(In reply to comment #10)
> Comment on attachment 479736 [details] [diff] [review]
> Patch
> 
> >+#tabs [anonid="tabs-children"] documenttab:only-child > .documenttab-container > .documenttab-close-container > .documenttab-close {
> >+  display: none;
> >+}
> >+
> >+
> > #tabs-controls {
> 
> extra space and that CSS selector is crazy long

fixed

http://hg.mozilla.org/mobile-browser/rev/7bac809eef70
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified fix on 20101008 builds of android and maemo. filed bug 602962 for screen orientation bug.
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus?(tchung)
litmus test: https://litmus.mozilla.org/show_test.cgi?id=13667
Flags: in-litmus?(tchung) → in-litmus+
You need to log in before you can comment on or make changes to this bug.