JRE load failure renders browser unusable for RH 6.0 users

VERIFIED INVALID

Status

P3
major
VERIFIED INVALID
19 years ago
15 years ago

People

(Reporter: nbaca, Assigned: edburns)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Branch build 2000-10-27-08MN6: Linux 6.0 (KDE)

Overview: Perform a Custom install. At the end of the installation it tries to
auto launch but fails. The console displays:

*** Registering sample JS components
There was an error trying to initialize the HPI library.
Please check your installation, HotSpot does not work correctly
when installed in the JDK 1.2 Linux Production Release, or
with any JDK 1.1.x release.
Could not startup JVM properly!
java_vm process: could not start Java VM
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable

- Tried restarting but the same error appears.
(Reporter)

Comment 1

19 years ago
Marking "rtm" since this is a basic function that should work.
Severity: normal → major
Keywords: rtm

Comment 2

19 years ago
what options in the custom dialogs did you select?
Assignee: ssu → sgehani

Comment 3

19 years ago
cc:lchiang. This problem is not happening on all linux boxes. I checked on her 
box, it has a KDE UI. Mine has Gnome(works fine for me). Custom install with 
whatever comes selected by default is showing this problem on nbaca's machine. 
Manually deleting the java plugin from the plugins folder allows the browser to 
launch otherwise this error is blocking user from launching the build.

Comment 4

19 years ago
cc: george, edburns

Updated

19 years ago
QA Contact: gemal → gbush

Comment 5

19 years ago
to date, I know nbaca and laurel having this problem.  I haven't heard about
this from anyone else so I'm not sure how widespread this is.
Samir: need you to investigate this. Does the Linux installer attemp to copy the
wrong (old) plugin files?
Whiteboard: [rtm need info]

Comment 7

19 years ago
Dan,
Nope the installer doesn't copy files from anywhere (like we do on Win32); it 
merely installs the JRE bits and makes a symlink to the real 
libjavaplugin_oji.so in the root of the plugins folder.

This is on my investigation queue.  Will pay the cited mail QA folks a visit.

Comment 8

19 years ago
Problem idenitified.  Users running a RedHat 6.0 distribution of Linux (kernel
rev ~2.2.5-22) cannot launch the browser successfully if they have Java 2
installed because when loading libjvm.so the browser process exits (at plugin
load time after autoreg'ing when the browser is coming up).

This prevents RH 6.0 users form running Netscape 6/mozilla if they Java 2 installed.

However, this works fine with a RH 6.1 distribution (kernel rev ~2.2.12-xx).
Also, if RH 6.0 users remove the plugins/java2 directory entirely then they can
start the browser successfully.

Pavlov, Akkana, McAfee,
What minimum version of glibc needs to be present?  Also, do we support RH 6.0
users as the minimum or RH 6.1?  I will attach the console output that
incriminates libjvm.so loading to provide more context for the latter questions.
Assignee: sgehani → edburns
Summary: Custom install fails to open Navigator → JRE load failure renders browser unusable for RH 6.0 users

Comment 10

19 years ago
RH 6.0 is pretty old now.  We should probably just say we require redhat 6.1,
then hope someone finds a workaround (does it work to uninstall kaffe or install
a later version?) which we can release note for people on 6.0 who don't want to
upgrade.

Comment 11

19 years ago
this happens for me too, I am running rh6.0 at work.
Agree with Akkana, we should recommend at least rh6.1,
and rel-note the remove-java-plugin workaround for rh6.0
users.

Comment 12

19 years ago
oh right, installing kaffe is a better workaround.
We should list both workarounds, some users might
not be able to install to kaffe to fix this problem.

Comment 13

19 years ago
let's get the wording for this and send to verah's release note tracking bug.  
Keywords: relnoteRTM

Comment 14

19 years ago
In the meantime, can we get this off the rtm radar?
[rtm-] there's nothing we can do in Netscape 6 to fix this, we'll just have to 
relnote the workarounds (upgrade your kernel or install kaffe instead)
Whiteboard: [rtm need info] → [rtm-]
(Assignee)

Comment 16

19 years ago
I concur with mcaffee.  Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Comment 17

19 years ago
shrir - can you get this into the release notes tracking bug?

Comment 18

19 years ago
sure..

Comment 19

19 years ago
installed on RH 6.1 successfully
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
I'm using a system that started as a rh6.0 system but has been upgraded along
the way.
[jks@d1 ~] java -version
java version "1.2.2"
Classic VM (build Linux_JDK_1.2.2_FCS, native threads, sunwjit)

I am currently running the 2.4.0 kernel.

Trying to start mozilla .7 results in:

[jks@d1 /usr/local/mozilla0.7] ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla0.7
  LD_LIBRARY_PATH=/usr/local/mozilla0.7:/usr/local/pgsql/lib
     LIBRARY_PATH=/usr/local/mozilla0.7:/usr/local/mozilla0.7/components
       SHLIB_PATH=/usr/local/mozilla0.7
          LIBPATH=/usr/local/mozilla0.7
       ADDON_PATH=/usr/local/mozilla0.7
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Registering plugin 0 for: "*","All types",".*"

...and then it just freezes, not eating up cpu but just sitting there.  No
window pops up.

If upgrading the kernel won't work, what will?  What is so special about rh6.0
that breaks mozilla?

Comment 21

18 years ago
I've have upgraded to RedHat 6.2 but the JRE still crashes on startup with
a shmget error?
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 22

18 years ago
Please ensure that your mozilla was ./configure'd --disable-debug and built 
with that configuration.  Furthermore, if you have 0.7 you have to do this:

  * To get 0.7 to work with Java on Unix, apply patch from 62489.

Then please re-test.

I'm marking invalid, please reopen if, when you do the above steps, the problem 
persists.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → INVALID

Comment 23

18 years ago
vfy invalid
Status: RESOLVED → VERIFIED
Could this be related to 67005, since when I got that error I was running Red 
Hat 6.0 with an updated kernel?  (The error I got was different, but I had used 
a different Java version.)

Comment 25

18 years ago
Upgrading glibc to 2.1.3 appears to resolve the problem

Comment 26

18 years ago
Note that this is also true on debian woody (testing). This wasn't true for the
0.9.2 version. Also, it does no more read jpeg images...

Comment 27

16 years ago
i had a very similar issue on redhat 6.2 - checked and manually installed the
plugin link - still no luck. 

then i added /usr/local/mozilla to the PATH and java now loads and browser no
more crashes =)

can any confirm this is still active
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.