page zooms in unexpectedly when momentum scrolling hits end of page and ctrl is hit

RESOLVED DUPLICATE of bug 574663

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 574663
8 years ago
8 years ago

People

(Reporter: Cam, Unassigned)

Tracking

({pp, ux-control})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

When you have inertial scrolling enabled on a macbook (Pro) or are using a magic mouse or magic trackpad, if you have "left over" momentum when you reach the end of a page (top or bottom) and hit ctrl, the page will rapidly zoom in. (not the screen itself which one might expect due to Mac system shortcuts that are similar, but this is just the page loaded in Firefox)

Reproducible: Always

Steps to Reproduce:
1. Ensure inertial scrolling is enabled in System Preferences (Requires a newer Mac and a software update)
2. Open Firefox if it isn't already open.
3. Scroll down or up so you are not directly at either end of a page.
4. Rapidly scroll towards one end of the page, such that if it were further away you would still reach it (scroll unnecessarily quickly)
5. When you reach the end of the page hit ctrl.
Actual Results:  
The page zooms in dramatically.

Expected Results:  
Nothing.

This doesn't happen in any cocoa apps I've tried it on, so perhaps this is a good time to make Camino into the Mac version of Firefox?
(Reporter)

Updated

8 years ago
Keywords: pp, ux-control

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574663
You need to log in before you can comment on or make changes to this bug.