Incremental layout of nested table wrong (Netscape Calendar Express)

RESOLVED DUPLICATE of bug 56201

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 56201
18 years ago
18 years ago

People

(Reporter: harishd, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-], URL)

(Reporter)

Description

18 years ago
Filing a bug for the issue that waterson raised ( "Jiggly netscape calendar")

Load  this sample ( Reload/ Shift Reload a few times - Notice the logo ):

<HTML>
<HEAD>
<BASE HREF=https://calendar-1.netscape.com>
<TITLE>Calendar Express Login</TITLE>
</HEAD><BODY>
<TABLE BORDER="1" BORDERCOLOR="#000000" BGCOLOR="#ffffff">
 <TR>
 <TD>
  <TABLE CELLPADDING="3" CELLSPACING="0" BORDER="1">
   <TR>
    <TD COLSPAN="2">
  <TABLE BORDER="0" WIDTH="100%">
   <TR>
        <TD>
         <IMG src="/nscal/images/english/splash_name.gif">
        </TD>
        <TD>
         <IMG src="/nscal/images/english/logo_small.gif" border=0>
        </TD>
      </TR>
     </TABLE>
    </TD>
   </TR>
  </TABLE>
 </TD>
 </TR>
</TABLE>
</BODY>
</HTML>
(Reporter)

Comment 1

18 years ago
since this affects calendar...nominating for rtm
Keywords: rtm

Comment 2

18 years ago
My impression of the severity of the problem: the page doesn't look good, but
it's not unusable.

My impression of the cause of the problem: we're not handling incremental reflow
(cause in this case by the images loading asynchronously) inside a 3-level
nested table where the outer tables have no width specified and the inner table
has %-width specified.  I think Chris has several bugs with a similar flavor.

Note to Eric and Lisa: Netcenter could work around this bug by adding width and
height information to the <IMG> tags on the page.  This would be a very good
idea for them to do anyway, because it makes loading on all browsers (that I
know of) much faster.
Summary: Wrong layout → Incremental layout of nested table wrong
chrisn, greggl -- Netcenter needs to modify markup to avoid triggering this issue.

Comment 4

18 years ago
please mark this rtm-  : per buster's assessment of the severity of this.

Gregg: are you responsible for this page?  I see it's Calendar Express so I'm
wondering this is maintained by IS.

Comment 5

18 years ago
No, I am not responsible for this page, will ask Netscape.com programming.

Comment 6

18 years ago
added "Netscape Calendar Express" to summary to help find duplicates.
Summary: Incremental layout of nested table wrong → Incremental layout of nested table wrong (Netscape Calendar Express)

Comment 7

18 years ago
*** Bug 58505 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
Marking rtm-.
Status: NEW → ASSIGNED
Whiteboard: [rtm-]

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago

*** This bug has been marked as a duplicate of 56201 ***
You need to log in before you can comment on or make changes to this bug.