Flickering resize effect for new maximized windows

VERIFIED WORKSFORME

Status

()

Core
Widget: Win32
VERIFIED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Matti, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100728 SeaMonkey/2.1a3pre and FF4b2

This is a recent regression and appeared around the same time as bug 575184

STR:
1) change the size of an open FF/SM window to a small size
2) maximize the window with the button in the title bar
3) open a new window with ctrl+n
4) a new window opens in the small and not maximized size and it will be resized immediately to maximized and that causes an ugly flicker effect.

mcsmurf confirmed this on IRC on winXP and SM trunk 20100728
(Reporter)

Comment 1

8 years ago
You get the same resize effect with popups :
https://bugzilla.mozilla.org/attachment.cgi?id=461252
(Reporter)

Updated

8 years ago
Duplicate of this bug: 586824

Comment 3

8 years ago
Hi,

Is any one working on fixing this bug? I just updated to Beta 5 and I still have the same problem. It is really annoying. Please any one fix it.

Regards,
Satish.

Comment 4

8 years ago
I am running Windows 7 in VirtualBox, and I can also reproduce this.

(In reply to comment #1)
> You get the same resize effect with popups

With popups, for me it looks like this:
- new popup opens at the size and position of a non maximized window
- popup resizes to full-screen and back again (only if main window is in full-screen mode)
- popup resizes to final size and moves to final position

I will attach a screenshot

Comment 5

8 years ago
Created attachment 473035 [details]
screenshot

Comment 6

8 years ago
Yeah... this issue seems to be prevalent across the versions of Windows. I guess this needs to be fixed ASAP, as it is giving a very bad user experience.

Regards,
Satish.

Comment 7

7 years ago
Just now updated to 4.0b6. Still happens. Sad.

Updated

7 years ago
Depends on: 597576

Comment 8

7 years ago
post the fix that landed in bug 574690 today.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 9

7 years ago
The flickering affect of popup windows seems to be fixed in 4.0b8pre.
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.