Open Bug 582773 Opened 12 years ago Updated 4 years ago

[Regression] Middle-clicking tab when alps touchpad drivers are installed shows auto-scroll marker instead of closing the tab

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

Tracking Status
blocking2.0 --- -

People

(Reporter: shadow2531, Unassigned)

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100728 Minefield/4.0b3pre
Build Identifier: 

Dell Inspiron 3800
WinXP SP3
Alps trackpad mouse drivers <http://shadow2531.com/opera/alps/AlpsA00.EXE>
KME (Keymouse) MD-335 ps/2 optical wheel mouse

If I middle-click on a tab to close it, it doesn't close and I instead get an auto-scroll marker.

This happens with the Alps drivers only (as opposed to MS Wheel mouse drivers at least) and only when certain other applications are open like:

taskmgr.exe
Media Player Classic Home Cinema 
Gvim 
The windows charmap program 
AbiWord 

When one of those apps is open and Firefox is focused (as opposed to being in the background), clicking the middle mouse button over a tab doesn't fire a WM_MBUTTONDOWN event and Firefox gets confused and shows the auto-scroll marker instead.

This is also a problem in Opera 10.5x+ (breaks auto-scroll in pages too in Opera 10.5x+) and Chrome. But, it's not a problem in Opera 10.10, Firefox 3.7, IE8, Safari, Notepad++, Foobar, K-Meleon and Midori etc. It seems to be a problem in browsers that support putting tabs in the title bar or tabs on top perhaps like Firefox 4, Chrome and Opera 10.5+ do.

Also see <http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/6601537e196492c3#> for discussion about this.

I also filed this for Chrome. See <http://code.google.com/p/chromium/issues/detail?id=50135>.

Since most apps work fine, there's got to be something that Firefox 4.x does differently. Maybe it's as simple as using the right window classname.

A hint: When the alps touchpad drivers are installed, in any program, while one of those listed programs is open, middle-clicking the title bar will cause the title bar to gray out (lose focus) and the auto-scroll marker to show. That's the same type of thing that happens when clicking on a Firefox tab when I try to close it.

Reproducible: Always
With this code, middle-clicking the window area (the white part) should close the app. But, with the alps drivers installed and taskmgr.exe running, middle-clicking the white area shows an auto-scroll cursor instead and it's clear that the middle-button down event isn't being fired.

If however, I focus the desktop (to remove focus from the app) and then middle-click over the area in the app, the app will be focused and middle-click will indeed close the app. So, it only happens when the app is focused, which I can also confirm is true for Firefox.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression
Are we sure this is us, not the driver doing something odd?
Signs point to the driver being goofy imo. But, the way Firefox was coded before, it didn't expose the driver bug. And, IE and lots of other apps don't expose the bug.

So, it's either a driver bug or misunderstanding about how certain mouse drivers work. Either way, I think it should be worked around *if* possible, since it worked fine before and all.

Note that in the case of older computers with Alps touchpads, there may not be newer drivers to try. If the people that make the Alps drivers (I guess the problem is present even on newer laptops with newer drivers) were to provide a fix, it probably would only work on newer drivers for newer hardware. That may be an acceptable fix though *if* someone can get in touch with their devs.
blocking2.0: ? → -
(In reply to comment #3)
> Are we sure this is us, not the driver doing something odd?

It's almost certainly the driver being stupid.  We've been through no end of pain because of these (Bug 507222, Bug 589529, etc) but if we can find a workaround we probably should take it (though this is relatively minor compared to the usual complete failure to scroll)
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.