Closed Bug 583058 Opened 12 years ago Closed 12 years ago

Scrolling sometimes ruins youtube.com visual view

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 579736

People

(Reporter: ogi, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

Since I upgraded to Firefox 4 Beta 2, when viewing YouTube videos and do window scrolling using the mouse, the content is not scrolled properly. It looks like window content is not repainted properly. Visually it's like a few horizontal lines are taken and repeated in the whole window content - some scrolling problem. The flash rectangle with the video is the only thing that looks OK. When trying to "Print Screen", everything is fixed before taking screenshot, so no attachment is attached.

Reproducible: Sometimes

Steps to Reproduce:
1. go to youtube video
2. scroll window

Actual Results:  
repeating multiple lines

Expected Results:  
correct display

flash part is OK. Print Screen key fixes display.
Attached video Video demonstration
Using a cheap Nokia, I tried to catch demonstration of the problem. Unfortunately, the resolution is awfully low. What becomes clear is that the problem happens only when scrolling to top, not to bottom. Not always reproducible.
This photo demonstrates that few horizontal lines are taken and all of the display is filled with them. The number of lines and the lines themselves change in each scrolling movement upwards.
It's worth noting that I updated from Beta 1 and I don't remember such problem in Beta 1, so it should be something with the retained layers.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579262
Duplicate of bug: 579736
You need to log in before you can comment on or make changes to this bug.