Normal Tabs that were once App tabs become App tabs after reopening Firefox

RESOLVED DUPLICATE of bug 580512

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 580512
8 years ago
8 years ago

People

(Reporter: Ryuji, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre

Normal tabs that were once App tabs will turn back into app tabs after reopening Firefox. This will make users confused or annoyed, which is bad.

Reproducible: Always

Steps to Reproduce:
1. Open a few tabs
2. Turn them into App tabs 
3. Close Firefox
4. Open Firefox 
5. Use Firefox to serve the Internet roughly about 10 to 15 min 
 5.1 Use App tab to serve the internet
 5.2 Use Normal Tab to serve the internet
6. Turn App tab into Normal Tab 
7. Close Firefox
8. Open Firefox
9. You will see App tab has reappeared, which is wrong since you have already make them into normal tabs.

10. Note: if You fail to see the error, go back to step 5 and repeat STR from step 5 to step 9 again. 
Actual Results:  
Normal tabs Became App tabs

Expected Results:  
Normal Tabs remains as Normal Tabs
(Reporter)

Updated

8 years ago
Blocks: 551849

Comment 1

8 years ago
This only works if you remember tabs currently.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580512
You need to log in before you can comment on or make changes to this bug.