[Mac] [OOPP] Beach balling when I trigger the flash context menu

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: marcia, Assigned: BenWa)

Tracking

({regression})

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Seen while running  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre

STR:
1. Load blip.tv come.
2. Right click to expose the context menu
3. Try to select one of the "quality" options
4. If you move the cursor away from the menu, you see beach balling.

I have also seen the same behavior when performing the same operations on youtube.com
blocking2.0: --- → ?
Assignee

Comment 1

9 years ago
I'll take this bug. I know what the problem here. My surprise is that on my machine I don't get 'beach balling', I just have the rendering pause during the duration of the menu.
Assignee: nobody → b56girard
Status: NEW → ASSIGNED
blocking2.0: ? → betaN+
Assignee

Updated

9 years ago
Summary: [Mac] Beach balling when I trigger the flash context menu → [Mac] [OOPP] Beach balling when I trigger the flash context menu
Assignee

Comment 2

9 years ago
Previously we used to detect if we we're in a paint event using 'mView != [NSView focusView]' except this doesn't work with out-of-process. My change instead checks if we dispatched a paint event. This appears to be more reliable.
Attachment #466020 - Flags: review?
Assignee

Updated

9 years ago
Attachment #466020 - Flags: review? → review?(joshmoz)

Updated

9 years ago
Attachment #466020 - Flags: review?(joshmoz) → review+
Assignee

Comment 3

9 years ago
Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/5e9c05dbe8d6
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Assignee

Comment 4

9 years ago
Posted patch Fix leak (obsolete) — Splinter Review
I forgot to un-comment 2 lines that release memory.

Also does this object doesn't need to be release-ed since it doesn't alloc right?
  NSTimer *eventTimer = [NSTimer timerWithTimeInterval:EVENT_PROCESS_DELAY
                             target:eventProcessor selector:@selector(onTick)
                             userInfo:nil repeats:TRUE];
Attachment #466020 - Attachment is obsolete: true
Attachment #466187 - Flags: review?
Assignee

Updated

9 years ago
Attachment #466187 - Flags: review? → review?(joshmoz)
Assignee

Updated

9 years ago
Attachment #466187 - Attachment is patch: true
Attachment #466187 - Attachment mime type: application/octet-stream → text/plain
Assignee

Updated

9 years ago
Attachment #466020 - Attachment is obsolete: false
Assignee

Comment 5

9 years ago
Sorry for bugspam, found another problem :(.
Attachment #466187 - Attachment is obsolete: true
Attachment #466190 - Flags: review?(joshmoz)
Attachment #466187 - Flags: review?(joshmoz)

Comment 6

9 years ago
(In reply to comment #4)

> Also does this object doesn't need to be release-ed since it doesn't alloc
> right?
>   NSTimer *eventTimer = [NSTimer timerWithTimeInterval:EVENT_PROCESS_DELAY
>                              target:eventProcessor selector:@selector(onTick)
>                              userInfo:nil repeats:TRUE];

It's not that it does or doesn't alloc (you don't really have a way to know what it does), but whatever it does it returns an autoreleased object which means it isn't your responsibility to release it.

Updated

9 years ago
Attachment #466190 - Flags: review?(joshmoz) → review+

Updated

9 years ago
Attachment #466190 - Flags: approval2.0+
You need to log in before you can comment on or make changes to this bug.