Animated Gif rendering is slow and affects mouse movement

VERIFIED DUPLICATE of bug 44588

Status

()

Core
ImageLib
P3
major
VERIFIED DUPLICATE of bug 44588
17 years ago
17 years ago

People

(Reporter: Michael Wiktowy, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In a page with many animated gifs. The gif animation is very slow and in Linux
(Redhat 6.2, Sawmill WM and XFree86 3.3.6) the mouse movement gets very laggy
and the pointer jumps as you move it.

This is related to Bug 44588 but adds mouse performance problems.

Comment 1

17 years ago
 I suspect that this is partly an artifact of what video card someone has
(and how well your X server supports it). My system shows no perceptible
lag, although X plus Mozilla are soaking up almost all of the CPU to do
this. With a video card that is not well supported, XFree86 might well be
spending a lot of (unresponsive) time shoving pixels around.

For comparison purposes: RH 6.2, XFree86 4.0.1, Matrox G400 MAX (32MB)
at 1280x1024 24-bit colour. (And a lot of memory and CPU.)

Comment 2

17 years ago
Yeah, that pegs my PIII 450. I'm confirming this, since it is a pretty
unacceptable performance issue. I think it is a dup, though I can't find it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Blocks: 61478

Comment 3

17 years ago
Dupe is of bug 44588, if someone can mark it as such. I don't seem to be able 
to.
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 44588 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.