Timeout for loading error pages (win.documentLoaded == true)

RESOLVED DUPLICATE of bug 503277

Status

RESOLVED DUPLICATE of bug 503277
8 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

Trunk
regression

Details

(URL)

(Reporter)

Description

8 years ago
With the landing of bug 579943 an issue is now more visible as how it was before. For error pages we run reliable into timeouts. See also bug 503277 for more details about that problem.

waitFor: Timeout exceeded for 'function () { return win.documentLoaded == true;}'

So what shall we do for 1.4.2? Reverting the old functionality? Updating the tests to not use waitForPageLoad but waitForElement, or fixing bug 503277?

Somehow win.documentLoaded turns into undefined after 2 or 3 iterations in the loop and never is set back to a valid value. Not sure why that happens.

I would say it is important for the next beta release.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503277
(Reporter)

Updated

8 years ago
Whiteboard: [mozmill-1.4.2?]
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.