UI for tab-modal prompts

RESOLVED DUPLICATE of bug 562258

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 562258
8 years ago
7 years ago

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 461772 [details] [diff] [review]
WIP v1

This bug might touch a line or two of toolkit/, but it almost exclusively involves modifying code in browser/ to get tab-modal prompts up and running in Firefox.

I'll change the dependency on bug 562258 to bug 59314, once stuff gets duped over.

This depends on bug 130078, since we would really like to be able to draw the tab-modal prompt over the content window, rather than having to hide the content window.
Attachment #461772 - Flags: feedback?(dolske)
(Reporter)

Comment 1

8 years ago
Created attachment 461773 [details] [diff] [review]
modded version of bug 562258's patch v.2 to apply before applying the WIP patch
(Reporter)

Updated

7 years ago
Attachment #461772 - Flags: feedback?(dolske)
(Reporter)

Updated

7 years ago
Attachment #461773 - Attachment description: apply this modified version of bug 562258's patch v.2 before applying this bug's WIP v1 → modded version of bug 562258's patch v.2 to apply before applying the WIP patch
(Reporter)

Comment 2

7 years ago
Now that bug 130078 has landed, I'll see what I can do with the overlay.
Assignee: nobody → fryn
Rolling this into the main tab-modal patch.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562258
(Reporter)

Updated

7 years ago
Attachment #461772 - Attachment is obsolete: true
(Reporter)

Updated

7 years ago
Attachment #461773 - Attachment is obsolete: true
(Reporter)

Updated

7 years ago
Assignee: fryn → nobody
You need to log in before you can comment on or make changes to this bug.