Helper Applications listing is blank

VERIFIED DUPLICATE of bug 50914

Status

SeaMonkey
Preferences
P3
normal
VERIFIED DUPLICATE of bug 50914
18 years ago
13 years ago

People

(Reporter: David Perry, Assigned: matt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Saw a similar bug listed for Linux (bug 50914), but no mention of other OSes
(specifically Win95/98). I'm running (from Help|About):Mozilla/5.0 (Windows; U;
Win98; en-US; m18) Gecko/20001027 .

Expected behaviour:  Helper Applications dialog lists all MIME file types,
allowing user to click on one and edit/delete it.

Actual behavour: Helper Applications dialog is blank.

Note: the helpers *are* being properly added using "New Type..." button, they
just aren't being shown.  Here's how I discovered this:

From the Preferences/Helper Applications dialog, I pressed the "New Type..."
button, and filled the resulting "New Type" dialog with the following:
Description: Compressed file
File extension: zip lha lzh
MIME type: application/zip
Application to use: "C:\Program Files\Norton Antivirus\Navw32.exe" /download

When I originally tried this, pressing the "OK" button had no apparent effect --
not even the dialog was closed.  Pressing it again (and every time I try to
"re-add" this type) gives a new dialog "Helper Application Exists" with the text
"A helper already exists for the MIME type 'application/zip'. Do you want to
replace it?"  Selecting "OK" dismisses that dialog, but the "New Type" dialog
remains open.  I can only dismiss that dialog with the "Cancel" or "X" (close)
buttons.

But when I click on a link with that MIME type, it pops up a dialog asking
whether I would like to open the file using the application I specified, or save
it to disk.  (Aside: the "Always ask me before opening or saving files of this
type" is disabled. Separate bug/feature/not yet implemented?)

Sample link: http://dark.x.dtu.dk/~grumbel/pingus/pingus-0.4.0-binary-win32.zip
(Warning: it's a big file. It's the only one I could find in a pinch that was
application/zip .)

Comment 1

18 years ago
--> preferences, perhaps backend? seeing as well on new trunk builds
Assignee: asa → matt
Status: UNCONFIRMED → NEW
Component: Browser-General → Preferences
Ever confirmed: true
QA Contact: doronr → sairuh
QA Contact: sairuh → shrir

Comment 2

17 years ago
This also happens in Linux. In fact I've never seen the Helper Applications
preferences work any other way so I had always assumed they didn't work yet! The
behaviour is exactly the same as what was described on Win 98.
(Reporter)

Comment 3

17 years ago
I created a new user profile, and now the listing of helper applications shows,
and adding new apps works as expected.  Are user profiles incompatible between
builds, or is something bigger going on?

Comment 4

17 years ago
If you have a very old profile, you might see this. Read comments in bug 
50914.Thx!

*** This bug has been marked as a duplicate of 50914 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verifying as a duplicate of 50914 
'Helper application panel listing is blank, cannot add mime type when using old 
profile'
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.