Closed Bug 583573 Opened 11 years ago Closed 11 years ago

Closing an unresponsive popup windows crashes Firefox 4 beta 2

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 579782

People

(Reporter: john, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 ( .NET CLR 3.5.30729)

reconfiguring a Thomson Speedtouch ST546 DSL modem, the initial setup is carried out in a series of popup windows. 
At end of config process clicking on the "Finish" "button" is supposed to close the popup, in FF 4 B2 nothing happens. (FF 3 all releases the window closed as expected.)
Closing the popup manually causes FF to crash, some crash reports may have been filed, however I cannot confirm as we were offline for part of the time.

Reproducible: Always

Steps to Reproduce:
1. login to speedtouch modem (usually http://192,168,1,254)
2. run through initial setup of modem.
3. when prompted enter ID & PW set in step 2.
4. click of "finish"
5  wait - I ahve waited for up to 5 minutes just in case things were just slow.
6  manually close the popup. - crash

7. Restart FF, everything (except the popup) will restore.

Actual Results:  
Firefox crashes

Expected Results:  
popup should have closed without incident. 
In FF 3, the popup closes and the the main windows refreshes showing the new state of the modem.
Here are some of the Crash Ids
bp-6b44fc51-4cd6-11dc-8b53-001a4bd46e84
bp-56cb1a54-4cd6-11dc-bfd7-001a4bd46e84
bp-511387cc-4cd6-11dc-be32-001a4bd43e5c

Here are more if you need them.
those don't appear to be reports, please click on each of them in turn to submit them. once you do so, their ids should change. we need the replacement ids.
(In reply to comment #4)
> those don't appear to be reports, please click on each of them in turn to
> submit them. once you do so, their ids should change. we need the replacement
> ids.
They were from the list about:crashes, however from the wrong end, my mistake,
these are the latest crash reports due to this problem, UUIDs  -
2547e5be-0b43-42eb-9ae4-512272100803
7dd1af8c-d6c3-4bd6-a89b-f0c502100803
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579782
You need to log in before you can comment on or make changes to this bug.