Javascript: FormData + xhr level2 generates invalid multipart request

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
9 years ago
2 years ago

People

(Reporter: werner.punz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs a testcase from the reporter])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

I tried to send an ajax upload via FormData and xhr level2, so far the send worked, but the generated multipart request is invalid because it lacks a divider definition and a content length definition. Setting the divider definition from outside did not help because the send request then generated its own divider without acknowledging an already present divider definition in the request header.

Reproducible: Always

Steps to Reproduce:

Just see the details
Actual Results:  
Data is sent but cannot be decoded because the sent data is an invalid multipart request!


Expected Results:  
A correct http multipart post request.
Can you still reproduce with the latest build? <http://nightly.mozilla.org/>

If so, could you attach a testcase and describe the actual results you see with the testcase and the results you expect to get.
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [needs a testcase from the reporter]

Comment 2

2 years ago
I don't see anything actionable here, so given the time that has passed I think it's not worth keeping this ticket open. If this bug does still happen, please reopen the ticket and provide the information requested in comment #1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Incomplete, if we just don't have the data to work on....
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.