mac crash trying to access cgi generated clock image.

RESOLVED WORKSFORME

Status

()

P3
major
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: hociman, Assigned: pavlov)

Tracking

Trunk
mozilla1.0.1
PowerPC
Mac System 9.x
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m18) Gecko/20001025
BuildID:    20001025

This page is crashing Mozilla.  The Finder says it is a type 3 error.	

Reproducible: Always
Steps to Reproduce:
Try to load that page.

Actual Results:  Crash.

Expected Results:  Loaded the page properly.

Comment 1

18 years ago
qawanted, need mac people to check this
Keywords: qawanted

Comment 2

18 years ago
I do not see a crash with 103008 mozilla trunk build on Mac OS 9.  I do see a
failure of http://tycho.usno.navy.mil/cgi-bin/nph-usnoclock.gif?zone=UTC&ticks=60
 to load.  
(Reporter)

Comment 3

18 years ago
After updating to the October 30 nightly build, the page does load.  However,
the link that Asa Dotzler mentions above (a java app?) is crashing my computer.
 To be more specific, I cannot even move the mouse.  Holding the Apple key and
pressing the programmer's button on my G3 gets the mouse working again, but that
is all...I still have to do a cold restart using the reset button.
Summary: Browser crashed wh trying to access site. → Browser crashed when trying to access site.

Comment 4

18 years ago
I think that the problem that we are both seeing on that page has been isolated
to the animated GIF.  Over to Imagelib.
Assignee: asa → pnunn
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: doronr → tpreston

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

18 years ago
Image is a cgi, not a simple animated gif.
We're talking about the clock cgi.

site location:
http://time.greenwich2000.com/

I'm updating the test url field to the cgi location:
http://tycho.usno.navy.mil/cgi-bin/nph-usnoclock.gif?zone=UTC&ticks=60

Comment 6

18 years ago
changing summary.
-p
Summary: Browser crashed when trying to access site. → mac crash trying to access cgi generated clock image.

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 7

18 years ago
This bug is behaving differently with build 2000120708.  While it still crashes
my computer, I do not have to resort to a cold restart.  I can hold down the
Apple key and press the programmer's button, thus putting me in debug mode, and
I can type "G FINDER" at the prompt and get back to the Finder.  (When I first
discovered this bug, going into debug mode in the Finder only let me move my
mouse.  I couldn't even type "G FINDER".)  When I do this, the Finder reports
Mozilla's crash as a type 2 error.  When I first discovered this bug, the Finder
was reporting it as a type 3 error.
(Reporter)

Comment 8

18 years ago
With build 2001010209 on Mac OS 9.0.4, the cgi clock does not crash my machine.
 However, the cgi clock does not function.  The clock just sits there on the
page and never starts counting time.  It displays a few words, one at a time,
before beginning its count, and it never gets past the first word (which is
actually the acronymn U.S.N.O.).  Nominating for mozilla0.8, removing crash from
the keywords, and lowering severity to major.
Severity: critical → major
Keywords: crash
(Reporter)

Updated

18 years ago
Keywords: mozilla0.8
(Assignee)

Updated

18 years ago
Blocks: 66959
(Assignee)

Updated

18 years ago
Blocks: 66966

Updated

18 years ago
Keywords: mozilla0.9

Updated

18 years ago
Keywords: mozilla0.8.1

Updated

18 years ago
Keywords: mozilla0.8

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 9

18 years ago
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: ASSIGNED → NEW

Comment 10

18 years ago
Although this does not crash on Mac build 2001040309, the image does not update
Whiteboard: [imglib]

Comment 11

18 years ago
Here a little more information that I found out.  I believe the original URL is 
messed up on the site but I poked around and found another one at 
http://tycho.usno.navy.mil/utclock.html that freezes my whole mac, hope this is 
helpful (Mac build 2001043008)

Comment 12

17 years ago
Terri: is this still happening?
(Reporter)

Comment 13

17 years ago
The URL has changed.

http://tycho.usno.navy.mil/estclock.html

While this is not crashing, it isn't working properly.

Comment 14

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 15

17 years ago
I loaded the page on BuildID 2002-02-15-08 for MacOS 9.2.2 and it caused a
browser and system crash about five seconds after the page was loaded.

Talkback ID TB3003308Y
stephend, could you attach the talkback of TB3003308Y here? thanks.

Comment 18

17 years ago
I tried downloading
http://tycho.usno.navy.mil/cgi-bin/nph-usnoclock.gif?zone=EST;ticks=11 from wget
with the --server-response option and got no HTTP headers at all in the
response. wget returned error: "10:30:07 ERROR -1: Malformed status line." My
point is that the crash might not be caused by ImageLib, but by header parsing.

The related images at URL
http://tycho.usno.navy.mil/cgi-bin/gifclock.gif?zone=EST and other files does
return valid HTTP headers. I was not able to reproduce this idependently without
Apache being too smart to let me do bad things.
(Reporter)

Comment 19

16 years ago
Does not crash 2002091014.  The clock doesn't operate properly though.  It ticks
for a few seconds and then stops, though Mozilla appears to be fine.  Operates
properly on 1.2b for OS X, if that means anything for you programmers.

Comment 20

16 years ago
no crash using Mac OS 9 trunk build 2002122608, closing as WFM, please reopen if
you still see a crash
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

16 years ago
Comment 19 still applies.  Is that a server side problem or a Mozilla problem? 
Should this be reopened?
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.