Error 400: Bad Request when loading GMail -- (NS_ERROR_FILE_CORRUPTED) [nsIBrowserHistory.registerOpenPage]

RESOLVED DUPLICATE of bug 572223

Status

()

--
major
RESOLVED DUPLICATE of bug 572223
8 years ago
8 years ago

People

(Reporter: msclrhd, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre

When trying to log on with GMail I am getting a page saying "Bad Request -- Error 400".

None of the links at http://blogoscoped.com/forum/133251.html worked.

This was ok with the previous build, but broke with this update.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
The Error Console is reporting the following:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [nsIBrowserHistory.registerOpenPage]"  nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)"  location: "JS frame :: chrome://browser/content/tabbrowser.xml :: anonymous :: line 504"  data: no]
Summary: Error 400: Bad Request when loading GMail → Error 400: Bad Request when loading GMail -- (NS_ERROR_FILE_CORRUPTED) [nsIBrowserHistory.registerOpenPage]
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Keywords: regression
Please retry tomorrows build., a cookie changed got backed out.
You probably have to remove the stored cookie for google.
(In reply to comment #2)
> Please retry tomorrows build., a cookie changed got backed out.
> You probably have to remove the stored cookie for google.
I suspect this is the cookie change (bug 572223), and the error in comment 1 is unrelated.  It doesn't exactly clear up with a new build though, you'll need to actually clear the duplicate cookies that got created.
(Reporter)

Comment 4

8 years ago
Yeah, updating Minefield and clearing all cookie history resolved this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 572223
Although, the corrupt issue is something else entirely.  Is that 100% reproducible?  If so, can you see if it is also reproducible in Firefox 3.6?  If it isn't, would you be willing to send me your places.sqlite file?  We may have found a bug in SQLite.
blocking2.0: ? → ---
(Reporter)

Comment 7

8 years ago
I no longer have the profile that exhibited the issue(s), sorry. I have a 64-bit Windows machine that I haven't upgraded yet, so I'll keep an eye out for this cropping up again.
You need to log in before you can comment on or make changes to this bug.