scribd.com website stops loading data or stops rendering data if "firefox" is not present in UA string

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: [not reading bugmail], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre

page stops loading all the page content.  Each manual page is using GetElementByID to get data from what looks like another web location.

Reproducible: Always

Steps to Reproduce:
Open URL
let page load for awhile
scroll down past page 29
Actual Results:  
Lot of blank manual images or content, as the webpage stops showing or downloading data after page 29

Expected Results:  
Webpage should load all content

works oddly enough in 4.0b1, though I cannot seem to nail down when it regressed, I tested builds back to 6-20 already.  No builds seems to load the entire content after 4.0b1 either.
(Reporter)

Updated

8 years ago
Keywords: regression, regressionwindow-wanted, relnote
Keywords: relnote
Version: unspecified → Trunk

Comment 1

8 years ago
WFM on Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100803 Minefield/4.0b3pre ID:20100803055502
(Reporter)

Comment 2

8 years ago
Its 130+ manual pages total and only the first 30 only are returning data.
For what it is worth, I get data after the first 30 sometimes; never past 60ish so far, though. This is on OS/X so changing OS to all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Created attachment 462926 [details]
Minefield and Chrome comparison: Minefield not displaying scribd properly

I can confirm that Minefield 4.0b3 is not rendering scribd pages correctly: the attached showed Minefield displaying blank pages, where Chrome is properly displaying both text and ads

URL being displayed: http://www.scribd.com/doc/35374801/Prop-8-Ruling
(Reporter)

Comment 5

8 years ago
I think the network stops fetching data first, and some of the pages do not seem to stay displayed when scrolling up and down past those that render or where fetched.  Note also testing without any imagelib prefs set like decode on draw.
(Reporter)

Comment 6

8 years ago
bz, any idea where this should go?
That really depends on when it regressed and what regressed it....

Do we have anything reliable steps to reproduce?  Or anything else that might give us a regression range?
(Reporter)

Comment 8

8 years ago
Well, on the URL noted in the URL field, I open that, let it sit, it eventually stops loading the entire webpage.  I tried to download several nightlies to see, but maybe each one I need to test each nightly with a new profile, I gave up after testing about 30 or 40 builds.

basically each page of the document has code like one of these:

<script type='text/javascript'>
    (function() {
        var pageParams = {"origHeight": 489, "origWidth": 900, "fonts": [13, 0, 1], "pageNum": 8};

        pageParams.containerElem = document.getElementById("outer_page_8");
          pageParams.contentUrl = "http://html2.scribdassets.com/44m3k7e45cl8xa8/pages/8-2a6354c1e7.jsonp";
        var page = docManager.addPage(pageParams);
      })();
  </script>
(Reporter)

Comment 9

8 years ago
BTW, 3.6.8 works fine too.
> it eventually stops loading the entire webpage

Every time, but in a different spot?  Or does it sometimes load it?

> testing about 30 or 40 builds

Unless the bug is not reliably reproducible, you shouldn't need to test more than about 9 builds to go all the way back to when 3.6 branched...
(Reporter)

Comment 11

8 years ago
(In reply to comment #10)
> > it eventually stops loading the entire webpage
> 
> Every time, but in a different spot?  Or does it sometimes load it?

With the particular URL testcase, it always stops at page 29 of the document, other pages might look like they are there if you scroll really fast up and down past the pages.  

> 
> > testing about 30 or 40 builds
> 
> Unless the bug is not reliably reproducible, you shouldn't need to test more
> than about 9 builds to go all the way back to when 3.6 branched...

Ok, that make sense.  Though when I found it was working on 4.0b1, I was trying to see if when that might of had a regression before it was build, so I started testing more builds right before.  

I did another test, and I think I found what the core issue seems to be around.  UA sniffing. :-/ 3.6.8 works, 4.0b1 works, but not 6-20 or 8-4 for example or any build leading up to 4.0b1.  

I tested both a few nightlies builds before and after 4.0b1 including 6-20 and 8-4, with and without UA spoofing.  When I added say extra.notfox = firefox/3.6.8 or firefox/4.0b1 the page fetched all the ads and URLs including all 132 page loads.

It might be there are so many domains or there is some crazy logic to kill loading once ads or something fails.  

Can anyone else confirm doing UA spoofing fixes the basic problem
(Reporter)

Comment 12

8 years ago
And is there anything we can about it?  Seems like an obscure issue, but just wondering.
Well, we can start using "firefox" as the appname for nightlies.  Or stop using it for releases.... ;)
(Reporter)

Comment 14

8 years ago
Ah, right on! 572665 \o/.   I suppose we could flag this for evangelism if UA sniffing is all it.
(Reporter)

Comment 15

8 years ago
(In reply to comment #4)
> Created attachment 462926 [details]
> Minefield and Chrome comparison: Minefield not displaying scribd properly
> 
> URL being displayed: http://www.scribd.com/doc/35374801/Prop-8-Ruling

Jennifer, I can confirm this also works if I add UA Spoofing, but still doesn't explain why Alice might not have seen it though.

I guess UA sniffing issues doesn't quite call it a regression, so removing keywords.
(Reporter)

Updated

8 years ago
Keywords: regression, regressionwindow-wanted

Comment 16

8 years ago
(In reply to comment #15)
> (In reply to comment #4)
> > Created attachment 462926 [details] [details]
> > Minefield and Chrome comparison: Minefield not displaying scribd properly
> > 
> > URL being displayed: http://www.scribd.com/doc/35374801/Prop-8-Ruling
> 
> Jennifer, I can confirm this also works if I add UA Spoofing, but still doesn't
> explain why Alice might not have seen it though.

I always check regression of trunk with UA Spoofing(Firefox3.6.8).
Because almost web site determine kind of browser with UA string.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 17

8 years ago
Presumably, any non-Firefox Gecko browser has the same problem.

http://geckoisgecko.info/  has directions for Scribd to fix this sort of thing by sniffing for capability (and rendering engine if absolutely necessary), rather than UA name.

cl
Blocks: 334967
Hardware: x86 → All
Summary: scribd.com website stops loading data or stops rendering data → scribd.com website stops loading data or stops rendering data if "firefox" is not present in UA string
Tried with a seamonkey UA without issues.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.