Closed Bug 584185 Opened 14 years ago Closed 14 years ago

loading Linux Libertine Opentype Font causes Hang/Freeze

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 583715

People

(Reporter: matafagafo, Unassigned)

References

()

Details

(Keywords: hang, regression, testcase)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 ( .NET CLR 3.5.30729)

Firefox Freeze when acesse this URL Firefox Freeze

Reproducible: Always

Steps to Reproduce:
1.Acesse URL
2.Firefox freeze
3.
Actual Results:  
Freeze

Expected Results:  
Show page
Is the "Freeze" reproduceable? Even in Safe-Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
(In reply to comment #1)
> Is the "Freeze" reproduceable? Even in Safe-Mode?
> https://support.mozilla.com/en-US/kb/Safe+Mode

Yes, it happens even in Safe Mode.
I Just tried to access the URL in other computer running Windows Vista and the problem don`t happened.
May be a Win 7 OS specific problem ?
I will try to determine what exactly in that page is causing the freeze.
I tried again with my Win 7 OS and use NoScript to control the page load, with NoScript activate a realized that the problem (freeze) happens when I FF loads the opentype fonts referred in a CSS file (general.css).
All the times that I authorized (via NoScript) the fonts load, my FF freeze.
I'm working in generate a small sample file.
To use you need to download the other file too, the opentype font
This is the Opentype font download from the URL that Freezes FF.
Ok, I'm created a reduced sample. Just download the two files on the same directory and open the html file with FF 4 b2.]
I hope this helps.
Well, on WinXP there's no Hang/Freeze like on the original URL.
Can you get a Stacktrace for the Hang/Freeze following the Instructions mentioned here: https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg ?
And do you know/can test if this works without Hang/Freeze on 1.9.2 Branch, i.e. Fx 3.6.8, and thus might be a Regression?
Attached file WinDbg Stacktrace
Ok, checking on Win7 (Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100805 Minefield/4.0b4pre ID:20100805041002) i am able to repro the Hang.

Attaching a WinDbg Log.
First Frame:

   0  Id: af4.a2c Suspend: 1 Teb: 7ffde000 Unfrozen
ChildEBP RetAddr  
002379a8 779bb992 ntdll!KiFastSystemCallRet
002379ac 779bb9b5 GDI32!NtGdiGetCharABCWidthsW+0xc
002379cc 7631aa3d GDI32!GetCharABCWidthsI+0x1b
00237d04 7631b00e USP10!LoadGlyphMetricsWithGetCharABCWidthsI+0x2d
00237d34 763402d5 USP10!GetGlyphAdvanceWidths+0x1de
00237d58 76345e90 USP10!CUspShapingFont::GetGlyphDefaultAdvanceWidths+0x25
00237e04 763430fa USP10!ShapingGetGlyphPositions+0x320
00237efc 76316645 USP10!ShlPlace+0x20a
*** WARNING: Unable to verify checksum for G:\Internet\Browser\Firefox.Trunk\xul.dll
00237f44 631d38e1 USP10!ScriptPlace+0x165
00237f88 631f002b xul!UniscribeItem::Place(void)+0x121 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxuniscribeshaper.cpp @ 228]
002385b4 631a45e6 xul!gfxUniscribeShaper::InitTextRun(class gfxContext * aContext = 0x05458230, class gfxTextRun * aTextRun = 0x067a6c40, wchar_t * aString = 0x00238958 " ???", unsigned int aRunStart = 0, unsigned int aRunLength = 2, int aRunScript = 61)+0x39b [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxuniscribeshaper.cpp @ 635]
00238688 631b0a53 xul!gfxGDIFont::InitTextRun(class gfxContext * aContext = 0x00000000, class gfxTextRun * aTextRun = 0x053679d0, wchar_t * aString = 0x00000000 "", unsigned int aRunStart = 0x67a6c58, unsigned int aRunLength = 0, int aRunScript = 1)+0x176 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxgdifont.cpp @ 182]
00238704 6317afec xul!gfxFontGroup::InitTextRun(class gfxContext * aContext = 0x05458230, class gfxTextRun * aTextRun = 0x067a6c40, wchar_t * aString = 0x00238958 " ???", unsigned int aTotalLength = 2, unsigned int aScriptRunStart = 0, unsigned int aScriptRunEnd = 2, int aRunScript = 61)+0xb3 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxfont.cpp @ 2233]
0023886c 6317af4b xul!gfxFontGroup::InitTextRun(class gfxContext * aContext = 0x05458230, class gfxTextRun * aTextRun = 0x067a6c40, wchar_t * aString = 0x00238958 " ???", unsigned int aLength = 2)+0x8f [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxfont.cpp @ 2214]
00238890 631e0559 xul!gfxFontGroup::MakeTextRun(wchar_t * aString = 0x00238958 " ???", unsigned int aLength = 2, struct gfxTextRunFactory::Parameters * aParams = 0x002388f8, unsigned int aFlags = 0x1100101)+0x47 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxfont.cpp @ 2190]
00238ee4 63335a22 xul!TextRunWordCache::MakeTextRun(wchar_t * aText = 0x0023a300 "???", unsigned int aLength = 1, class gfxFontGroup * aFontGroup = 0x0630ed30, struct gfxTextRunFactory::Parameters * aParams = 0x00238fbc, unsigned int aFlags = 0x1100100)+0x5b9 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\gfx\thebes\gfxtextrunwordcache.cpp @ 693]
00238f10 631e615c xul!MakeTextRun(wchar_t * aText = 0x0023a300 "???", unsigned int aLength = 1, class gfxFontGroup * aFontGroup = 0x00237dc4, struct gfxTextRunFactory::Parameters * aParams = 0x00238fbc, unsigned int aFlags = 0x1100100)+0x3a [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nstextframethebes.cpp @ 445]
0023a2d0 631cde50 xul!BuildTextRunsScanner::BuildTextRunForFrames(void * aTextBuffer = 0x0023a302)+0x9cc [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nstextframethebes.cpp @ 1806]
0023b2fc 631d1d9b xul!BuildTextRunsScanner::FlushFrames(int aFlushLineBreaks = <Memory access error>, int aSuppressTrailingBreak = 2325956)+0xa0 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nstextframethebes.cpp @ 1238]
*** WARNING: Unable to verify checksum for G:\Internet\Browser\Firefox.Trunk\mozjs.dll
0023b370 667ac54f xul!BuildTextRuns(class gfxContext * aContext = 0x0ff98b57, class nsTextFrame * aForFrame = 0x00012484, class nsIFrame * aLineContainer = 0xffffff9a, class nsLineList_iterator * aForFrameLine = 0xeb9e3800)+0x2eb [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nstextframethebes.cpp @ 1172]
Btw, this regressed (roughly speaking) between
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1 (http://hg.mozilla.org/mozilla-central/rev/65c30e4ee631)
and
Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2 (http://hg.mozilla.org/mozilla-central/rev/961f253985a4)
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Summary: Firefox Freeze → loading Linux Libertine Opentype Font causes Hang/Freeze
Version: unspecified → Trunk
Looks like!
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: