Closed Bug 584344 Opened 12 years ago Closed 12 years ago

Inspector Panels become top-most window.And Active application window is covered by Inspector Panels.

Categories

(DevTools :: General, defect)

x86
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alice0775, Assigned: rcampbell)

References

Details

(Whiteboard: [kd4b4])

Attachments

(2 files)

Attached image screen shot
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100804 Minefield/4.0b3pre ID:20100804040859
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100804 Minefield/4.0b3pre ID:20100804040859

Inspector Panels become top-most window,
Active application window is covered by Inspector Panels.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open UAR ( ex. HOME http://www.mozilla.org/projects/minefield/ )
3. Alt > Tools > inspect (Ctrl+Shift+I)
4. Open application window such as explorer, notepad and any other windows application.

Actual Results:
 Inspector Panels are always top-most window.
 Active application window is covered by Inspector Panels.

Expected Results:
 Inspector Panels will be top for the concerned browser, 
 However, Inspector Panels should not cover other active window application.
Whiteboard: [kd4b5]
this is partially by design at this point. Before, the default level of the panels would sometimes cause the highlighter (also a panel) to obscure parts of the tree or style panel if they were over the browser.

There's another option I can try which sets the tree and style panels to "floating". This will make them disappear if the user clicks away from the browser and may be preferable in some cases.

I'll attach a patch to try out.
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
floating panels that disappear when losing browser focus. I think these may be preferable for now.
Attachment #462779 - Flags: review?(gavin.sharp)
Whiteboard: [kd4b5] → [kd4b4]
Comment on attachment 462779 [details] [diff] [review]
[checked-in] floating panels

This is a tiny, tiny patch. Moving to dolske in hopes that we can give this a whirl for b4. I do think this will be a distinct improvement in behavior.
Attachment #462779 - Flags: review?(gavin.sharp) → review?(dolske)
(In reply to comment #3)
> Created attachment 462779 [details] [diff] [review]
> floating panels
> 
> floating panels that disappear when losing browser focus. I think these may be
> preferable for now.

When a focus returned to a browser again, is the state of each panel restored?
If not, I do not think that this solution is too desirable.
Comment on attachment 462779 [details] [diff] [review]
[checked-in] floating panels

>-           level="top"
>+           level="floating"

level="floating" is the default value when a titlebar is present, so you could remove the level attribute.
does it hurt to be explicit here?
I'm not sure there's a win. Presumably we'll always want the default behavior for titlebar panels. I think I prefer just removing the attributes.
Comment on attachment 462779 [details] [diff] [review]
[checked-in] floating panels

Yeah, what Gavin/Enn said. Let's just remove the level attribute.

Marking r+/a+ since that's a trivial change and can land directly.
Attachment #462779 - Flags: review?(dolske)
Attachment #462779 - Flags: review+
Attachment #462779 - Flags: approval2.0+
agreed. Thanks for the review!
Comment on attachment 462779 [details] [diff] [review]
[checked-in] floating panels

http://hg.mozilla.org/mozilla-central/rev/50b46f4f4045
Attachment #462779 - Attachment description: floating panels → [checked-in] floating panels
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.